Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Windows Messenger


  • Please log in to reply
7 replies to this topic

#1
smilinjim

smilinjim
  • Member
  • 6 posts
I recently installed Windows 2000 in a Hotstream version SP5 Build 5.1.2195, updated from SR-1a, Volume Select. I have since used the available Autopatcher updates. I went to install the needed software, APC-C (the UPS guys) PowerChute Business Edition Basic, and found that it required the Windows Messenger service to be running, which I found in looking in Administrative Services to be altogether missing. Ordinarily, I would be very happy to not have this running, because I have often heard it to be a security risk, but this software apparently counts on it for its communication between the various constituent elements. I do not know if this would have been uninstalled in running the SP5 Hotstream, I guess it really does not matter, what would be a much more germaine and meaningful question, about which I could very much use help and would appreciate assistance, would be how now to get it back. It would be a bonus if there were a way to do it without a whole new install of Windows and updating everything -- the machine in question is dog slow, which does not help. I have seen lots of sites discuss re-enabling the service once turned off, but nothing about restoring it if it is just not there. Thanks very much!!


How to remove advertisement from MSFN

#2
Electrician

Electrician

    Member

  • Member
  • PipPip
  • 113 posts
  • OS:XP Pro x86
  • Country: Country Flag
Do not confuse Windows Messenger (the IM crapo) with the Messenger Service!
You should see it listed under Services as "Messenger". That is what the program wants.
Not as big a risk - but it was being MIS-used by web sites and spammers to throw pop-up
messages at people.
Messenger has not gone missing from any USP build that I know of. (Now, nlited on the other hand....)

#3
smilinjim

smilinjim
  • Member
  • 6 posts
Thanks. Those are easy to confuse, but this time, I have them straight, and I went to check in Services, but did not see "Messenger" at all. Hence, the concern.

I was going to say I did not nLite, but I then realized that was how I integrated the "Un-official Service Pack Five". That was one of the suggestions I saw, and saw recommended. If there is a better way, I would welcome learning it. I guess if I have to, I could go back and re-integrate 5.1.2195, without nLite, and "repair" Windows, and see if that installs the Windows Messenger service.

Would that be your recommendation, and if so, how would I go about it, please? Is there a different way, also, like, adding the select files for Windows Messenger in a surgical addition?

I did not otherwise, on purpose, do anything special or goofy, of which I am aware, to try to lead to losing that service. But maybe, as you may be suggesting, there was a gift from nLite, which I have heard sometimes results in some unexpected effects.

#4
-I-

-I-

    win2k Freak

  • Member
  • PipPipPipPip
  • 639 posts
if you only used nlite to slipstream the sp5 - your cd wil not be enlited (as in no components will be removed / unless you specificaly say it has to),

have you tied going to the add remove windows components and looking for the messenger service there? (im not realy shure if it is posible to enable/disable it there - but i cant go look - im not running win2k atm).

alco check services.msc
[message of the .....whatever]
Dont be a luser*!*@msnf.org: Ask Good Questions. , read the microsoft guide, google-it-yourself
Do NOT use pirated software, there is free opensource software for allmost every task you seak!
Where is the "any key" ???

#5
Electrician

Electrician

    Member

  • Member
  • PipPip
  • 113 posts
  • OS:XP Pro x86
  • Country: Country Flag
smilinjim
I have never had messenger removed by integrating the USP's.
I integrate them into my source (on disk) by doing this;
"w2ksp51.exe /passive /n /integrate:E:\Create\W2ksp4_USP51"
(for example) then IF I need to reduce size (often do), I use nlite for that. Of course, I also use HFslip to integrate all the current patches, etc.
If you make a new CD, you can certainly do an in-place upgrade, which
will add components and "restore" DLL's to the version on CD.

#6
smilinjim

smilinjim
  • Member
  • 6 posts
I was going to try creating a new build with Unofficial Windows 2000 Service Pack 5.1.2195.24 Refresh --

and to ask if I were to use nLite, if I should use the integrate Service Pack option, or to install the USP5 like a hotfix, in that section of the program.

But, I like what you were just seeming to suggest about streaming the pack from, I guess, I "run" command

"w2ksp51.exe /passive /n /integrate:E:\Create\W2ksp4_USP51",

but I have a question: What then is the E:\Create\W2ksp4_USP51? That would look like where the pack would have to go that you would have to create first, would that be right. I have C as hard drive, D as CD-Rom, E as CD-RW. Do you create a file and put the destination Windows 2000 source there to receive the USP5 to be integrated into it? So would that, for you be a Directory you have called W2ksp4_USP51, in "Create" on an E: hard drive, for you, or is the W2ksp4_USP51 the file name of some already slipstreamed Win2k version? (I am just not sure about the syntax of this command string.)

Thanks!

#7
Electrician

Electrician

    Member

  • Member
  • PipPip
  • 113 posts
  • OS:XP Pro x86
  • Country: Country Flag

But, I like what you were just seeming to suggest about streaming the pack from, I guess, I "run" command

"w2ksp51.exe /passive /n /integrate:E:\Create\W2ksp4_USP51",

but I have a question: What then is the E:\Create\W2ksp4_USP51?
-- That is the directory on my hard drive E: where I FIRST copied the contents of my install CD. (On 2k use xcopy or select all and remove the read-only flag).

That would look like where the pack would have to go that you would have to create first, would that be right.
--YES, see above statement.

I have C as hard drive, D as CD-Rom, E as CD-RW. Do you create a file and put the destination Windows 2000 source there to receive the USP5 to be integrated into it?
--You are correct sir.

So would that, for you be a Directory you have called W2ksp4_USP51, in "Create" on an E: hard drive, for you, or is the W2ksp4_USP51 the file name of some already slipstreamed Win2k version? (I am just not sure about the syntax of this command string.)

As I have several versions, of both XP and 2k, for different reasons, it is simply what I chose to call the folder.
(Seeing how it is from the 2k with SP4 CD and is intended for slipstreaming with the USP5.1)
But you get the point. Sorry, I wasn't more clear in my choice of words.

Thanks!
--You are most welcome.



#8
smilinjim

smilinjim
  • Member
  • 6 posts
Appreciate the reply and suggestions, and I loved the xcopy thing. I had used it once before, it was neat to learn more about it, it worked slick and it is a really cool tool. I really liked that, in theory, it would remove, by default, the read-only protection, which I was having trouble removing select-all, copy and paste. Well, when I did the xcopy, I found that the folder, and everything in it, was 'sanitized for my protection', and read-only. Moreover, it is very determined, and when I change folders, even granularly, individually, and then go back, they have reverted back to read-only. I tried the apply to this one and everything underneath, all the sub-folders, but, no-dice, nor to one-by-one.

Any idea why it does this thing, and what to do about it? I don't know if I can apply the USP if it is read-only. Thanks!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN