zedox

Microsoft Update, asks for activex even though added cab to HFCABS

23 posts in this topic

I've downloaded the MUWEB_SITE cab from the link on Tommy76's page placed it in the HFCABS folder.

It appears the files within this cab are present in SOURCESS however when I go to the Microsoft update website it asks to install activex controls...

I've also added WindowsUpdate20.exe, Package Installer 6.1.22.4 , windows update cab (IUCTL.cab) and the office update cab (OPUC4.cab).

Have I missed something else?

Thanks all, :thumbup

0

Share this post


Link to post
Share on other sites

I've added your exe to HFSVPACK, but microsoft update still asks to download active x controls?

0

Share this post


Link to post
Share on other sites

I'm guessing the DLLs didn't get registered properly. Which version of HFSLIP were you using?

0

Share this post


Link to post
Share on other sites

LAtest stable release, and the latest test release.

I've included...

IUCTL.CAB

LegitCheckControl.cab

OPUC4.CAB

MUWEB_SITE.CAB

in the HFCABS folder

and,

Super-Magician's selfextracting exe (Datastore.exe) in the HFSVCPACK folder

Windows update works fine, but microsoft update asks for activex controls.

Should also note, I use nLite to slipstream IE7

I've tested this without slipstreaming IE7 and Microsoft Update worked.

So I'm assuming IE7 requires different controls maybe?

0

Share this post


Link to post
Share on other sites

I've just checked the version number of MUWEB.DLL in system32 of my install and it matches that of MUWEB_SITE.CAB, why doesn it woooorkkkk!

0

Share this post


Link to post
Share on other sites

Think its the runonce problem caused by IE7.... Will test it by replacing the IE7 runonce dll with the old IE6...

0

Share this post


Link to post
Share on other sites

Funny... I never experienced this RunOnceEx problem... Not even when HFSLIP slipstreamed IE7 and didn't delete the IE7 version of iernonce.dll...

0

Share this post


Link to post
Share on other sites

o... well testing the install now with the ie6 iernonce.dll file.

Will report back when finished.

0

Share this post


Link to post
Share on other sites

Sure you aren't removing anything with nLite?

Open WindowsUpdate.log (not Windows Update.log) from the WINDOWS folder in Notepad and look for a "Setup: Checking whether self-update is required" header. Below that, you should see a bunch of files being referred to and some details on whether they need to be updated or not. Is everything OK there?

0

Share this post


Link to post
Share on other sites
2006-12-07 17:14:07 668 394 Setup Update required for C:\WINDOWS\system32\mucltui.dll: target version = 0.0.0.0, required version = 5.8.0.2469

Only file that comes up as missing.

0

Share this post


Link to post
Share on other sites

mucltui? That's gotta be a new file. It isn't part of any update package I know of...

I suppose it's the MU equivalent of wucltui.dll.

0

Share this post


Link to post
Share on other sites

I registered the MUCLTUI.DLL on a clean install.

Tried Microsoft Update and it's still requiring the ActiveX controls...

Ran out of ideas now!

0

Share this post


Link to post
Share on other sites

Can you try redownloading MUWEB_SITE.cab? I still have yet to test to see whether I encounter the same error with the latest release and IE7.

Will report back my findings as I soon as I get a chance!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.