Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

raffa

AutoUnattemnded.xml and image from

Recommended Posts

Remade my image & altered the ans file by the waik & getting this error:

"Windows can't resolve the metadata provided in the unattend answer files <Imageinstall> setting"

Heres the relevant part of the ans file:


<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<servicing></servicing>
<settings pass="windowsPE">
<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<DiskConfiguration>
<WillShowUI>OnError</WillShowUI>
<Disk wcm:action="add">
<ModifyPartitions>
<ModifyPartition wcm:action="add">
<Active>true</Active>
<Extend>false</Extend>
<Format>NTFS</Format>
<Letter>C</Letter>
<Order>1</Order>
</ModifyPartition>
</ModifyPartitions>
<DiskID>0</DiskID>
<WillWipeDisk>true</WillWipeDisk>
</Disk>
</DiskConfiguration>
<Display>
<ColorDepth>32</ColorDepth>
<HorizontalResolution>1024</HorizontalResolution>
<RefreshRate>60</RefreshRate>
<VerticalResolution>768</VerticalResolution>
</Display>
<DynamicUpdate>
<Enable>false</Enable>
</DynamicUpdate>
<ImageInstall>
<OSImage>
<InstallFrom>
<Path>d:\sources\install.wim</Path>
</InstallFrom>
<InstallTo>
<DiskID>0</DiskID>
<PartitionID>1</PartitionID>
</InstallTo>
</OSImage>
<DataImage wcm:action="add">
<InstallFrom>
<Path>D:\sources\install.wim</Path>
<MetaData wcm:action="add">
<Key>4</Key>
<Value>Windows Vista ULTIMATE</Value>
</MetaData>
</InstallFrom>
<InstallTo>
<DiskID>0</DiskID>
<PartitionID>1</PartitionID>
</InstallTo>
<Order>1</Order>
</DataImage>
</ImageInstall>

Any ideas fellas, have I populated too many fields in the disk area?

Edited by MAVERICKS CHOICE

Share this post


Link to post
Share on other sites
maxXPsoft    27

yes too many fields looks like

EDIT: No need for path here anymore either

This is all I have and works

<ImageInstall>
<OSImage>
<InstallTo>
<DiskID>0</DiskID>
<PartitionID>2</PartitionID>
</InstallTo>
<WillShowUI>OnError</WillShowUI>
<InstallFrom>
<MetaData wcm:action="add">
<Key>/IMAGE/Index</Key>
<Value>1</Value>
</MetaData>
</InstallFrom>
</OSImage>
</ImageInstall>

You can use either as mentioned

Image/Name

Image/Index

Edited by maxXPsoft

Share this post


Link to post
Share on other sites

Thanks Max, updating now.

EDIT: Appears good now & installing UA as it should. Very fast install too under half an hour. More setting & populating to do now.

Edited by MAVERICKS CHOICE

Share this post


Link to post
Share on other sites
jamieo    0

Glad to see everyone's got this nailed now. :)

Key: /IMAGE/DESCRIPTION

Value: Windows Vista ULTIMATE Updates disabeled

Will install the image, where <Description> is Windows Vista ULTIMATE Updates disabeled.

I didn't mention this option as I have not tested it and was unsure if it would work on it's own. Have you tested it yourself?

Would be useful to know if it's been proven... though I can't imagine when it would be useful unless you have two images with the same name - which you can't in a single .wim. Since the description doesn't seem to be shown during setup I guess you could use it as a tag to identify your default image and then whatever you call it your xml will pick the right one..

Jamie

Edited by jamieo

Share this post


Link to post
Share on other sites

@JamieO

All working very smooth. Must say in my experience you have to be very specific in making the answer file. Upon thousands of settings & variants can apply. Thank goodness for the help files & this forum. Mind you sh*t loads of testing as well.

Edited by MAVERICKS CHOICE

Share this post


Link to post
Share on other sites
FireGeier    0
...

I didn't mention this option as I have not tested it and was unsure if it would work on it's own. Have you tested it yourself?

Would be useful to know if it's been proven... though I can't imagine when it would be useful unless you have two images with the same name - which you can't in a single .wim. Since the description doesn't seem to be shown during setup I guess you could use it as a tag to identify your default image and then whatever you call it your xml will pick the right one..

Jamie

It was working for me using description as MetaData, too. Main thing is that Description will identify your image inside install.wim clearly.

I haven't thought about the sense of having these three options. Tested it only.

If you ask me, using /IMAGE/INDEX/ would already be enough to identify the right image clearly.

Martin

Share this post


Link to post
Share on other sites
jamieo    0

Thanks for the confirmations. I guess it's useful to have the choice.

I'm using the name key myself as I don't have to worry about the number and order of images inside the wim.

Cheers.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×