• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Sign in to follow this  
Followers 0
MDGx

98MP10 = WMP10 XP + XP SP3 Killer Replacements

111 posts in this topic

98MP10 Unofficial Killer Replacements: WMP10 XP + XP SP3 -> 98/98 SP1/98 SE/ME

Updated · 9-18-2010

98MP10 ReadMe Guide (English):

98MP10.EXE [9.1 MB, English].

98MP10 Guide Lizes-Moi (French):

98MP10.EXE [8 Mo, French].

All 98MP10 files.

Requires WMP9 already installed!

Windows 98 (FE = First Edition) + 98 SP1 require Unofficial WMP9 [13.3 MB, English] already installed!

98MP10 section @ MDGx.com.

98MP10 NEW Forum [this 1] = please update your bookmarks/favorites.

98MP10 OLD Forum = closed.

See 98MP10.TXT for complete details.

98MP10 installs ALL 98SE2XP + 98SEMP10 files!

98SE2XP + 98SEMP10 are both OBSOLETE!

_____________________________________

9-18-2010 Update

98MP10 English edition: added WMV9AP SMPTE VC-1 Codec [WVC1DMOD.DLL 10.0.0.1218]:

http://www.mdgx.com/wmp.htm#ENC

+ Marxo's WMP9/WMP10/WMP11 WMZ skin:

http://marxo.deviantart.com/art/Windows-Media-Player-11-58761119/

_____________________________________

2-17-2010 Update

Added 98MP10FR.EXE + ReadMe Guide French edition. [thank you CharlesF]

_____________________________________

12-23-2009 Update

Removed "RequiredEngine=SETUPAPI" from 98MP10.INF to fix install bug [?]. [thank you supem]

_____________________________________

12-21-2009 Update

Added newer files from WinXP N (European Edition without WMP) SP3 Q943604 Media Pack:

BLACKBOX.DLL 9.0.0.4504

DRMCLIEN.DLL 9.0.0.4504 = new

DRMSTOR.DLL 9.0.0.4504 = new

DRMV2CLT.DLL 9.0.0.4504 = new

MPVIS.DLL 9.0.0.4504

MSNETOBJ.DLL 9.0.0.4504 = new

MSPMSP.DLL 9.0.1.57

MSSCP.DLL 9.0.0.4504

MSWMDM.DLL 9.0.1.56

WMPASF.DLL 9.0.0.4504

WMPCORE.DLL 9.0.0.4504

WMPDXM.DLL 9.0.0.4507

WMPLOC.DLL 9.0.0.4504

WMPNS.DLL 9.0.0.4504

WMSDMOE.DLL 9.0.0.4504

UNREGMP2.EXE 9.0.0.4504

WMPLAYER.EXE 9.0.0.4504

WMP.OCX 9.0.0.4504

Except for the 4 new files above, all others are updated versions.

_____________________________________

12-10-2009 Update

Updated DEL_DRM.INF = does not delete/move/rename DRMCLIEN.DLL or any other DRM files anymore. It only un-registers them from the registry.

"HOW TO REMOVE DRM" section in 98MP10.TXT = updated to reflect these DRM changes.

This because reported bug with WMVCORE.DLL not working without DRMCLIEN.DLL present in %windir%\SYSTEM folder. [thank you whatever420]

Fixed shortcut creation.

_____________________________________

11-20-2008 Update

Added newer files from WinXP SP3:

WMV8DS32.AX 8.0.0.4000

WMVDS32.AX 8.0.0.4487

PLYR_ERR.CHM

WMPLAYER.CHM

BLACKBOX.DLL 9.0.0.4503

CABINET.DLL 5.1.2600.5512

MPVIS.DLL 9.0.0.4503

MSPMSP.DLL 9.0.1.57

MSSCP.DLL 9.0.0.4503

MSWMDM.DLL 9.0.1.56

WMPASF.DLL 9.0.0.4503

WMPCORE.DLL 9.0.0.4503

WMPDXM.DLL 9.0.0.4503

WMPLOC.DLL 9.0.0.4503

WMPNS.DLL 9.0.0.4503

WMSDMOE.DLL 9.0.0.4503

WMSTREAM.DLL 8.0.0.4487

MPLAYER2.EXE 6.4.9.1126

UNREGMP2.EXE 9.0.0.4503

WMPLAYER.EXE 9.0.0.4503

WMP.OCX 9.0.0.4503

_____________________________________

12-27-2007 Update

Added newer WMASF.DLL 10.0.0.4359 from WMP10 for WinXP SP2 Q941569 (MS07-068).

Enjoy.

0

Share this post


Link to post
Share on other sites

Now, if I want the improvements of the newer version of 98MP10 do I just install this new one even though the last one was already installed? Or would I need to restore the original backed up files first? It would be nice if just installing the new one took care of things.

Does the backup process let me toggle it off if the original 98SE, WMP files have already been backed up so I wouldn't want this install to overwrite them? I know 98SE2ME has that option.

0

Share this post


Link to post
Share on other sites
Now, if I want the improvements of the newer version of 98MP10 do I just install this new one even though the last one was already installed? Or would I need to restore the original backed up files first? It would be nice if just installing the new one took care of things.

Does the backup process let me toggle it off if the original 98SE, WMP files have already been backed up so I wouldn't want this install to overwrite them? I know 98SE2ME has that option.

1. Yes, 98MP10 installs all files every time you install it.

It's not [at least not yet] as sophisticated as 98SE2ME. ;(

2. No.

In order to keep your old files [backed up by 98MP10], you need to 1st uninstall 98MP10, and then reinstall it.

Again, 98MP10 is not [at least not yet] as sophisticated as 98SE2ME.

Maybe, in the future, I'll add file version check to make sure backups will not be overwritten.

Please note that this will add to the file size, and 98MP10 is already 7.5 MB.

BTW:

I'm actually considering deleting the entire backup section from the INF, because all files seem to work ok so far.

HTH

0

Share this post


Link to post
Share on other sites
and what about http://www.mdgx.com/files/MP923689.EXE

a.k.a wmvcore.dll

WMVCORE.DLL from this fix belongs to WMP9:

WMVCORE.DLL build 9.0.0.3353

Most files from 98MP10 are from WMP10.

But this WMVCORE.DLL belongs into the "ultimate" WMP9 build, which I'm [still] working on [soon...]. ;)

HTH

0

Share this post


Link to post
Share on other sites

Am I supposed to see the difference?

In "About.." there is written Windows Media Player Series 9 after installation.

:rolleyes:

0

Share this post


Link to post
Share on other sites

Hi. I'm new here and my english is not so good.

I would like to say that the problem with the menu in all explorer windows cited by Eck happened with me too after installing 98mp10. And so I uninstalled it..

Edited by rodrigo_rds
0

Share this post


Link to post
Share on other sites
I would like to say that the problem with the menu in all explorer windows cited by Eck happened with me too after installing 98mp10. And so I uninstalled it..
Hello, rodrigo_rds, and welcome to MSFN forums.

As I have told Eck, to my knowledge the explorer problem is not related to 98MP10.

HTH

0

Share this post


Link to post
Share on other sites
Am I supposed to see the difference?

In "About.." there is written Windows Media Player Series 9 after installation.

You need to read the ReadMe text file [98MP10.TXT = the "EXTREMELY IMPORTANT" section] for explanation why this happens:

http://www.mdgx.com/98mp10/98MP10.TXT

98MP10 adds newer WMP10 XP + WMP9 XP SP2 functionality to Windows 98 SE/ME

even if you do NOT see 10.x.x.xxxx build whenever you run WMPLAYER.EXE or

MPLAYER2.EXE in the Help -> About Windows Media Player dialog box.

FYI:

98MP10.TXT always pops up whenever you install 98MP10 as 1st installation step.

HTH

0

Share this post


Link to post
Share on other sites

@ MDGx do u know if DIVX.DLL 6.5.0.44 work on Win98SE we

have discussed this with older versions but this is the latest.Thanks

0

Share this post


Link to post
Share on other sites
@ MDGx do u know if DIVX.DLL 6.5.0.44 work on Win98SE we

have discussed this with older versions but this is the latest.Thanks

Have you tried it?

If you did, does it work ok in Win98 SE?

I have not tested it [yet].

0

Share this post


Link to post
Share on other sites
@ MDGx do u know if DIVX.DLL 6.5.0.44 work on Win98SE we

have discussed this with older versions but this is the latest.Thanks

Have you tried it?

If you did, does it work ok in Win98 SE?

I have not tested it [yet].

I been working from a Win2000 machine so i'm not able to test at the moment

0

Share this post


Link to post
Share on other sites

I tried running the enhancement to MP10 features but then my Zen Sleek Photo was not recognized by the player. I too didn't see a change in features (is it all under the hood, so to speak?) except that it wouldn't recognize my device. Returning to MP9, my device is recognized....

I've now tried it twice with same results. My Zen Sleek Photo is recognized fine with 9.0 but if I load this enhancement, then the Zen is not recognized...

Edited by jasinwa
0

Share this post


Link to post
Share on other sites
I tried running the enhancement to MP10 features but then my Zen Sleek Photo was not recognized by the player. I too didn't see a change in features (is it all under the hood, so to speak?) except that it wouldn't recognize my device. Returning to MP9, my device is recognized....

I've now tried it twice with same results. My Zen Sleek Photo is recognized fine with 9.0 but if I load this enhancement, then the Zen is not recognized...

Sorry, mate, I don't have such device, so I can't test it. :(
0

Share this post


Link to post
Share on other sites

no worries, just though you (and others) may want to know. Maybe there are others that have devices and can verify if seen in 9 and 10. If you have any portable device that can be seen with 9.....etc....(maybe not just a zen sleek issue).

Keep up the super work you do!

Jeff

0

Share this post


Link to post
Share on other sites

Sorry, mate, I don't have any portable devices.

Best wishes.

0

Share this post


Link to post
Share on other sites

98MP10 doesn't work well on Win ME.

http://www.image-share.net/image/4199/29.JPG

First error is: "error during loading of powrprof.dll", second error is "setupapi.dll not found".

Infact after 98mp10 installation, in c:\windows\system there is only setupapi.mp9 and not .dll:

http://www.image-share.net//image/4199/setupapi.JPG

Renaming setupapi.mp9 in setupapi.dll, and rebooting the problem is solved.

Instead to be advpack.dll, there is only advpack.mp9

Renaming in advpack.dll, I can finally uninstall my unofficial SP.

Edited by Max_04
0

Share this post


Link to post
Share on other sites
98MP10 doesn't work well on Win ME.

http://www.image-share.net/image/4199/29.JPG

First error is: "error during loading of powrprof.dll", second error is "setupapi.dll not found".

Infact after 98mp10 installation, in c:\windows\system there is only setupapi.mp9 and not .dll:

http://www.image-share.net//image/4199/setupapi.JPG

Renaming setupapi.mp9 in setupapi.dll, and rebooting the problem is solved.

Instead to be advpack.dll, there is only advpack.mp9

Renaming in advpack.dll, I can finally uninstall my unofficial SP.

Thanks for your feedback.

I have revised the installer.

Should work now.

Please try again on your WinME computer, and let me know how it goes.

98MP10.EXE [7.5 MB]:

http://www.mdgx.com/98mp10/98MP10.EXE

98MP10 Guide:

http://www.mdgx.com/98mp10/98MP10.TXT

0

Share this post


Link to post
Share on other sites

PROBLEMCHYLD:

98MP10 = 4-11-2007 update:

I have removed SETUPAPI.DLL [XP SP2].

HTH

0

Share this post


Link to post
Share on other sites

I downloaded WMP10 from other computer. Exists any way to use this file in installation (Offline obviously)?

0

Share this post


Link to post
Share on other sites
I downloaded WMP10 from other computer. Exists any way to use this file in installation (Offline obviously)?
What do you mean?

98MP10 is a complete package and installs everything you need on Win98/98SE/ME, which means installs all WMP10 files [offline, does not connect to any server to d/l files] compatible with 9x Oses, only if WMP9 was already installed, of course.

Please see the ReadMe for details:

http://www.mdgx.com/98mp10/98MP10.TXT

You don't need any separate WMP10 files.

And WMP10 on its own cannot install on 9x OSes anyway, WMP10 is only for XP/2003.

And you don't need to download WMP10 from any other computer, it is available from M$ servers:

http://www.mdgx.com/wmp.htm#WMP10

HTH [Hope This Helps]

0

Share this post


Link to post
Share on other sites

Hi, MDGx:

Way back then, you used to distribute:

ADVPACK.DLL 6.0.2900.2180

ASCTRLS.OCX 6.0.2900.2180

BROWSELC.DLL 6.0.2900.2180

as part of 98SE2XP. Then you reverted to older

files, and they aren't part of the present 98MP10.

Could you please tell me what issues did they cause?

I've looked arround both the forum and your site, but

didn't find any hint on what happened. And I found no

version history for 98MP10 that reached to 98SE2XP

times. Can you please help me? Thanks.

I'd be grateful also if other members of this forum who

had/have experience with these files were willing to report

their findings on their use. Is there anyone that still does

use any of them? Thank you all!

0

Share this post


Link to post
Share on other sites
Hey MDGX, I'm sure you remember my advice:

http://www.msfn.org/board/?showtopic=82947

well it's no longer useful for those sites as you can read at the link above you may wish to remove the link from 98mp10.php.

Thanks!

I have removed your tip from 98mp10.php [98MP10.TXT].

Thanks a lot for your feedback.

0

Share this post


Link to post
Share on other sites

Do you know if DivX.dll 6.6.1.4 works ok With Win98SE

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.