Roufneck

DrvComp v2007.08.09

77 posts in this topic

What i was hoping for was an the ability for your utility to read the .inf file and take all the files necessary for a driver to work and then add entries in the textsetup.sif and dossetup.inf. This way the drivers would be truley integrated in windows source instead of method 1 or method 2 for driver detection.

0

Share this post


Link to post
Share on other sites

Initializing Driver Compressor 2007.07.17.1246...

Source: 'C:\My Documents\drivers\rhine'

Destination: 'C:\MY DOCUMENTS\WINDOWS 2000\DRVCOMPRESSOR\Destination'

WHQL driver signing: 1

UseProvider: 0

Type: .x86

OS: 4.10.2222

OS language: English (United States)

OS locale: en_enu (0409)

Copy international driver files: 0

Expanding cabinet files...

Removing attributes from files...

Parse Error 3

[+] \FETNDIS.inf

[+] \winsetup\NTSetup.inf

Removing temp dirs...

Compressing cabinet files...

Compressing copied files...

Processed 2/2 .inf files in 0 min 7 sec 359 ms.

Completed

This is my log file while testing. Not sure about the Parse Error 3. It's pulling what seems to be the correct files and directory across to the destination but not doing any sort of compression, the files are just there.

The source is an x86 folder containing the files for a Rhine network card; no cab files are in there.

0

Share this post


Link to post
Share on other sites
What i was hoping for was an the ability for your utility to read the .inf file and take all the files necessary for a driver to work and then add entries in the textsetup.sif and dossetup.inf. This way the drivers would be truley integrated in windows source instead of method 1 or method 2 for driver detection.

Do you know what entries to add and where? Or do you have some links where I can get the info? It would save a lot of time compared to method 1 and 2.

Hmmm... The only problem I can think off is adding different (manufacture modified) drivers with the same file name. I somehow need to recreate the dir structure in the i386 folder.

0

Share this post


Link to post
Share on other sites
The source is an x86 folder containing the files for a Rhine network card; no cab files are in there.

Can you give me a link to the drivers you used? I tried with some Rhine network card drivers, but I cant reproduce it.

0

Share this post


Link to post
Share on other sites

Can you give me a link to the drivers you used? I tried with some Rhine network card drivers, but I cant reproduce it.

http://www.viaarena.com/default.aspx?PageI...mp;SubCatID=147

The file that I downloaded was rhine-ndism-x86-x64-368-setup.zip with two folders x86 and Vista.

I ran your tool on the x86 folder.

Edited by dbrunton
0

Share this post


Link to post
Share on other sites
The file that I downloaded was rhine-ndism-x86-x64-368-setup.zip with two folders x86 and Vista.

I ran your tool on the x86 folder.

I just saw that you use Windows 98 Second Edition. Think there is a problem with removing attributes from files. Could you try this file and post the log file?

Edit: Removed beta version.

Edited by Roufneck
0

Share this post


Link to post
Share on other sites

Initializing Driver Compressor 2007.07.19.1222...

Source: 'C:\My Documents\drivers\x86'

Destination: 'C:\MY DOCUMENTS\WINDOWS 2000\NEWTEST\Destination'

WHQL driver signing: 1

UseProvider: 0

Type: .x86

OS: 4.10.2222

OS language: English (United States)

OS locale: en_enu (0409)

Copy international driver files: 0

Expanding cabinet files...

Removing attributes from files...

Parse Error 3

ATTRIB -A -R -H -S C:\My Documents\drivers\x86\* /S /D

ATTRIB -A -R -H -S C:\My Documents\drivers\x86\* /S

Scan INF files...

[+] \FETNDIS.inf

[+] \winsetup\NTSetup.inf

Removing temp dirs...

Compressing cabinet files...

Compressing copied files...

Processed 2/2 .inf files in 0 min 11 sec 144 ms.

Completed

File compression is occurring on the copied files. This was occurring on the original exe as well. That I did not notice - too much of a hurry.

I think I was presuming that the app would place all the files into a cab file for some reason from reading the messages. Unsure as to the parse error but it is occurring on another driver file I tested. But compression of the extracted files is occurring on this one as well plus the parse error.

No, the app is doing what it is supposed to be doing, just my eyesight. Apologies.

There are no attributes on the files concerned being worked on.

Edited by dbrunton
0

Share this post


Link to post
Share on other sites

Coud you just created custum dirs under I386 directory and add those custom dirs under txtsetup.sif ? This will avoid the issue with the potential of drivers having the same name.

0

Share this post


Link to post
Share on other sites
Coud you just created custum dirs under I386 directory and add those custom dirs under txtsetup.sif ? This will avoid the issue with the potential of drivers having the same name.

I am already working on this and took nlite as an example. I have to solve a few minor problems and test it before I make it a public beta. So far it is looking good.

0

Share this post


Link to post
Share on other sites

Awesome !!!!!! How is it going with the integrating drivers ?

0

Share this post


Link to post
Share on other sites
Awesome !!!!!! How is it going with the integrating drivers ?

Still work in progress. I don't have much spare time now, but will try to finish it by the end of next week.

0

Share this post


Link to post
Share on other sites
Getting close ?

I think its working. However, there are some textsetup copy errors regarding to some .cat files. Haven't figured that out yet. But if someone wants to test and can find whats wrong.

Edit: removed beta version.

Edited by Roufneck
0

Share this post


Link to post
Share on other sites

I tested it on a few drivers and they integrated correctly as far aas I can tell. I need to do an install to make sure they install properly. Thank you for your efforts to this point. I am creating an autoit app that creates an unattended cd and am going to use your app to integrate the drivers. Awesome so far I will let you know what I find.

0

Share this post


Link to post
Share on other sites

Thanks for super tools... get install all my drivers but only nvidia networking driver will have problem with it... keep asking for the file that exist in the folder....

so i use the default original driver for nvidia network... so everything is fine...

Save **** a lot spaces =) thanks

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.