• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
boooggy

[RELEASE] Boooggy's WMP 11 direct integration solution

646 posts in this topic

boooggy,

I'm trying to integrate WMP11 in to the clean sources of WinXP SP2 Corp using Windows Media Player 11 Slipstreamer 0.71 and have an error:

System.InvalidOperationException: The section "ProductInstall.ReplaceFilesIfExist" does not exist!

â System.Text.Ini.SimpleIniEditor.ThrowNotFoundSection(String SectionName)

â System.Text.Ini.SimpleIniEditor._internalReadMethod(String Section, String Key, Boolean FirstInstanceOnly)

â WMP11Slipstreamer.Backend.CompressFiles()

â WMP11Slipstreamer.MainGUI.workerMethod(Object addonSettings)

Deleting "G:\VRMPVOL_RU\i386\wmp11temp"... Done!

The source being modified has not been damaged.

All changes have been successfully reverted.

I'm using all official fix's for WMP11 from this page.

Seems what en error caused last fix - KB935957.

Ditto for me too with 0.72 and that hotfix. So we should not use this hotfix? When you say "not really needed", does that mean you do the reg mod yourself?

0

Share this post


Link to post
Share on other sites

Hae! It's owesome. It's wrks fine.

Thank you. for making such a addons....

0

Share this post


Link to post
Share on other sites

updated the addons

all command prompts popups are hidden now

thx to ricktendo for the help.

0

Share this post


Link to post
Share on other sites
ya pat i know about that. u have to take the cabinet.dll from xp and put it in the same folder with slipstreamer.

addons updated: added kb932390 and kb933547.

also if anybody can offer me some hosting will be greatlly appreciated.......

I can offer you free hosting on my server if you like...

Just let me know

0

Share this post


Link to post
Share on other sites

I'm trying to run this on a DELL OEM XP Home ISO that has been patched to SP2 plus the lastest RVMupdatepack. I get this error:

WMP11Slipstreamer.ArchiveMethods+ArchiveProcessException: An error occurred while extracting "C:\1_cds\DELLHOMEOEM\i386\OEMBIOS.DA_". ---> System.IO.InvalidDataException: "OEMBIOS.DA_" does not seem to be a valid Microsoft cabinet file.
at System.IO.Compression.CabDecompressor..ctor(String filename)
at WMP11Slipstreamer.ArchiveMethods.NativeCabinetExtract(String cabFile, String destinationDirectory, Boolean log, DecompressorProgressCallback callback)
--- End of inner exception stack trace ---
at WMP11Slipstreamer.ArchiveMethods.NativeCabinetExtract(String cabFile, String destinationDirectory, Boolean log, DecompressorProgressCallback callback)
at WMP11Slipstreamer.Backend.DetectSourceType()
at WMP11Slipstreamer.MainGUI.workerMethod(Object addonSettings)

Deleting "C:\1_cds\DELLHOMEOEM\i386\wmp11temp"... Done!

The source being modified has not been damaged.
All changes have been successfully reverted.

With the exact same setup, but using XP Pro Retail, it runs flawlessly. Any ideas as to what could be the source of the problem?

0

Share this post


Link to post
Share on other sites

can u please send me the OEMBIOS.DA_ file from dell xp cd?

thx

0

Share this post


Link to post
Share on other sites

version 0.73 released

fixed detection on dell xp

some command promt are now hidden.

0

Share this post


Link to post
Share on other sites

updated addons

added kb935551 and kb935552

0

Share this post


Link to post
Share on other sites

How will it go if I integrate the swedish version of WMP 11 into my swedish version of Win XP Pro SP2? Will there be any problem at all/in the future with the hotfixes KB908536 and KB894871 integrated/installed?

bajs

0

Share this post


Link to post
Share on other sites
How will it go if I integrate the swedish version of WMP 11 into my swedish version of Win XP Pro SP2? Will there be any problem at all/in the future with the hotfixes KB908536 and KB894871 integrated/installed?

bajs

dont know....never tested on sweedish cause i dont know sweedish..... :P

but u can test in virtual enviroment and please report the result....thx

0

Share this post


Link to post
Share on other sites

updated the tweaked addon

changed the music service to default page of media services.

0

Share this post


Link to post
Share on other sites

i got some news for people that requsted a x64 wmp11 addon.

first version is almost done....only thing is that i need some testers. and i mean people that uses x64 on real machines.

so if anyone is interested please contact me via PM.

thx all.

0

Share this post


Link to post
Share on other sites

released addon for xp x64

contains all files from original wmp 11 x64 installer, including wga.

also contains all hotfixes for wmp 11 and my tweaks.

0

Share this post


Link to post
Share on other sites

Now that can only be good. :thumbup

Got the x64 version downloaded, will give it a go over the weekend!

0

Share this post


Link to post
Share on other sites
Now that can only be good. :thumbup

Got the x64 version downloaded, will give it a go over the weekend!

glad u got it....

but its still in work......almost near perfection.... :P

0

Share this post


Link to post
Share on other sites

Hi Boooggy,

I get this error when integrating the x86 tweaked version with all the hotfixes into an xp install with service pack 2:

System.InvalidOperationException: The section "ProductInstall.ReplaceFilesIfExist" does not exist!
at System.Text.Ini.SimpleIniEditor.ThrowNotFoundSection(String SectionName)
at System.Text.Ini.SimpleIniEditor._internalReadMethod(String Section, String Key, Boolean FirstInstanceOnly)
at WMP11Slipstreamer.Backend.CompressFiles()
at WMP11Slipstreamer.MainGUI.workerMethod(Object addonSettings)

I have been attempting to install your tweaked version for some time now and I've been 100% unsuccessful...I have no clue what I'm doing wrong! Today I got this error. Yesterday there would be no errors but I would get the stock version of wmp11 after running my iso in virtualpc.

Could you reiterate exactly how to install your tweaked version again, just go step by step so I know for sure I'm not screwing this up. I've tried using your slipstreamer, I've tried using nlite, I am lost.

:wacko:

Thanks for any help you can give!

0

Share this post


Link to post
Share on other sites

the err u got is because u use kb935957....that fix is not needed. anyway this little problem will be fixed in new version.

as if u want to use my addons u only had to add it to nlite hotfix page.

the addons already contain the fixes.

if u use slipstreamer and want tweaked version then u have to use first the slipstreamer. then after slipstreamer finishes u can use nlite.

remember that u dont have to remove any wmp with nlite.

0

Share this post


Link to post
Share on other sites

I don't have legal XP, and so, I have to turn off automatic updates and WGA ... so, does this method of slipstreaming work in that case? (I would slipstream WMP11 with your Slipstreamer)

0

Share this post


Link to post
Share on other sites
I don't have legal XP, and so, I have to turn off automatic updates and WGA ... so, does this method of slipstreaming work in that case? (I would slipstream WMP11 with your Slipstreamer)

well u should try it and see.....

0

Share this post


Link to post
Share on other sites

Hi Boooggy

So I've tried both methods you suggested several times, and it doesn't appear to have worked. I slipstreamed with your program with all the kb .exe's and used nlite w/out putting your addon in the hotfixes page. I also tried just using your addon cab in nlite.

There should be an orange button if the tweaked version installed correctly right?

0

Share this post


Link to post
Share on other sites
So I've tried both methods you suggested several times, and it doesn't appear to have worked. I slipstreamed with your program with all the kb .exe's and used nlite w/out putting your addon in the hotfixes page. I also tried just using your addon cab in nlite.

There should be an orange button if the tweaked version installed correctly right?

i dont know what u r doing but i tested lots of times and it works just fine, no matter what method i used.

yes there have to be an orange icon for tweaked version.

0

Share this post


Link to post
Share on other sites

hi boooggy,

I'm now using version 0.73.

Still, the slipstreamer is not happy with kb935957.

:blushing:

0

Share this post


Link to post
Share on other sites
hi boooggy,

I'm now using version 0.73.

Still, the slipstreamer is not happy with kb935957.

:blushing:

that fix is not needed...so please dont use it....

0

Share this post


Link to post
Share on other sites

Hi

Can I slipstream the same Windows Media Player setup for Win2003 Server?

Can't find WMP11 for Win2003 server :(

http://web.clicknet.ro/boooggy/

(*) In this source the slipstreamer automatically integrates hotfix KB913800 to prevent it from appearing on Windows Update.

(Ω) In this source the slipstreamer automatically integrates hotfix KB908536 and hotfix KB894871 to fix issues with the "Themes" service and out-of-box experience not starting respectively on 1st boot.

Are these also integrated on none english windows?

If so, is it safe?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.