Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

[RELEASE] Boooggy's WMP 11 direct integration solution

- - - - -

  • Please log in to reply
645 replies to this topic

#351
BikinDutchman

BikinDutchman

    Member

  • Member
  • PipPip
  • 231 posts

I see on the hotfix list, "KB941569". The link goes to Microsoft but there is no way to download it. Any other link? I found another link here,


See my recent post and responses


How to remove advertisement from MSFN

#352
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,334 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag

How did you guys know that this hotfix labeled as for XP was also for WMP 11?


if u go to the KB article u will see it is specified that this fix is only for wmp (all versions). and another prove is that u unpack it inside the the fix there are files specific for all versions of wmp.

#353
soporific

soporific

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 705 posts
Hey Boooggy,

Just wanted to say thanks for this, it worked as intended first time, no hassles whatsoever. Cheers!

Soporific.

#354
leadboots5

leadboots5

    Junior

  • Member
  • Pip
  • 64 posts
This breaks doesn't allow Ruckus to get licenses for songs as far as i can tell. it has a problem with the DRM.

Edited by leadboots5, 11 February 2008 - 10:38 PM.


#355
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,334 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
leadboots
is there any demo i can try? cause it seems i cant find it on that site.....

#356
leadboots5

leadboots5

    Junior

  • Member
  • Pip
  • 64 posts
i sent you a pm

#357
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,334 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
leadboots
thanx for yor pm. i tested installing that ruckus player...downloaded songs and they were working nice played in ruckus player.
then i closed it and played the songs in wmp11 integrated with wmp 11 slipstreamer. alll were good.
only one little thing.......downloads werent working in IE6 ....so i had to install IE7.....

#358
leadboots5

leadboots5

    Junior

  • Member
  • Pip
  • 64 posts
hmm alright. no idea whats up then. thanks for trying.

#359
Petr

Petr

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 981 posts
  • OS:98SE
  • Country: Country Flag
Hello,

I'm trying to slipstream MP11 to Windows XP using the latest slipsteamer (this is the first time I use it) and both for English and Czech version I receive always this error:
WMP11Slipstreamer v0.991
Detected source: Windows™ XP Professional SP2

Hotfixes:
windowsmedia11-kb928788-x86-intl.exe
windowsmedia11-kb929399-v2-x86-intl.exe
windowsmedia11-kb929773-x86-intl.exe
windowsmedia11-kb932390-x86-intl.exe
windowsmedia11-kb933547-x86-intl.exe
windowsmedia11-kb935551-x86-intl.exe
windowsmedia11-kb935552-x86-intl.exe
windowsmedia11-kb939209-x86-intl.exe
WindowsMedia11-KB939683-x86-CSY.exe
windowsmedia11-kb942264-x86-intl.exe
windowsmedia11-kb943335-x86-intl.exe
windowsmedia11-kb944110-x86-intl.exe
windowsmedia11-kb944882-x86-intl.exe
WindowsXP-KB908536-v2-x86-CSY.exe
WindowsXP-KB941569-x86-CSY.exe

System.IO.FileNotFoundException: Soubor E:\WXPCS-MP11\i386\wmp11temp\Fixes\WM11\PortableDeviceWMDRM.dll nebyl nalezen.
Název souboru: E:\WXPCS-MP11\i386\wmp11temp\Fixes\WM11\PortableDeviceWMDRM.dll
   v System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   v System.IO.FileInfo.get_Length()
   v Epsilon.Win32.PeEditor..ctor(String pathToPe)
   v WMP11Slipstreamer.Backend.standardHotfixApply(String fixesFolder, Dictionary`2 hotfixFileDictionary)
   v WMP11Slipstreamer.Backend.ApplyFixes()
   v WMP11Slipstreamer.MainGUI.workerMethod(Object addonSettings)

Deleting "E:\WXPCS-MP11\i386\wmp11temp"...  Done!

The source being modified has not been damaged.
All changes have been successfully reverted.

Any idea what may be wrong?

Regards,

Petr

#360
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,334 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
petr
please try only the hotfixes linked on my site.......
908536 will not work integrated with slipstreamer.
u should use nlite to integrate it after u use slipstreamer.


edit
tested and without 908536 all works perfect

Edited by boooggy, 14 February 2008 - 10:11 AM.


#361
Kurt_Aust

Kurt_Aust

    Master of trial, error & Google

  • Member
  • PipPipPipPip
  • 551 posts
I get this error



when creating a limited account in Windows XP Pro x64 edition.


Tweaked WMP11 under v0.991 with the following hotfixes:

WindowsMedia11-KB929399-v2-x64-INTL.exe
WindowsMedia11-KB936782-x64-ENU.exe
WindowsMedia11-KB939683-x64-ENU.exe
WindowsMedia11-KB941569-x64-ENU.exe


EDIT:

It appears to be a regression bug, I dropped everyone's favorite hotfix (KB941569) and tried again but the error still occurs. The problem did not exist with version 0.96 of the slipstreamer.

Edited by Kurt_Aust, 15 February 2008 - 01:52 AM.


#362
Kelsenellenelvian

Kelsenellenelvian

    WPI Guru

  • Developer
  • 8,767 posts
  • OS:Windows 7 x64
  • Country: Country Flag
"limited account" Thats gotta be an issue with permissions. I'll bet Boooggy can find a way around it.

#363
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,334 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
that err its not caused by any hotfix kurt...it caused by the new entries i added in the .inf so that wmp 11 x64 install should be ok.
i am trying to fix but its a pain in the rear.....GOD i hate x64.....

Edited by boooggy, 15 February 2008 - 01:18 PM.


#364
BikinDutchman

BikinDutchman

    Member

  • Member
  • PipPip
  • 231 posts
x64: Setuperr.log errors:

Boooggy: After integrating WMP11x64 with slip streamer 0.99i in a clean WinXPx64 SP2 I get loads of errors in Setuperr.log.

I believe that did not happen with version 0.98i; can you put old versions back on the download location?

I attach my Setuperr.log

Attached Files


Edited by BikinDutchman, 16 February 2008 - 07:46 PM.


#365
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,334 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
dutchman
first of all please tell me exatly how u create the install?
then if u remove .cat files....
it seems also that u get a file copy error ....which means your source is broken.

#366
BikinDutchman

BikinDutchman

    Member

  • Member
  • PipPip
  • 231 posts

which means your source is broken.


Boooggy, I believe my WinXPx64 set is allright. I do not get these errors if I do not use the slipstreamer. Does that tell you anything?

#367
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,334 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
dutchman.....
u didnt tell me what exactly u did......to prepare the install...

#368
BikinDutchman

BikinDutchman

    Member

  • Member
  • PipPip
  • 231 posts

dutchman.....
u didnt tell me what exactly u did......to prepare the install...


Boogy, I did a WinNT32 install from a Windows XP x64 SP2 installation (copied from the CD and SP2 slipstreamed).

That Windows XP x64 SP2 installation has always worked so far, also with IE7 and hotfixes integrated with nLite.

The errors show up only recently after integration of WMP11. I tried several things but could not find the problem.

I have a suspicion that it has to do with the WinNT32 installation. I had similar issues with that before.

I will now go back to basics, fresh source and CD install, and report as soon as I am done with that.

And this get boring but yet want to repeat: you do a great job for something so complicated :thumbup.

#369
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,334 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
thx for your reply.
i found some little buggies in x64 install that i already fixed and will be in next version that we work on.
please have a little patience......
@kurt aust
your err also fixed.


ps. god i hate x64.....(the way microsoft did it :lol: )

Edited by boooggy, 18 February 2008 - 01:25 PM.


#370
BikinDutchman

BikinDutchman

    Member

  • Member
  • PipPip
  • 231 posts
Integrating WindowsServer2003-KB941569-x86-ENU.exe in WMP11

Hi Boooggy, I found another very unlikely way to cause some problems:
-I used slipstreamer 99 to integrate WMP11 and all fixes into a Windows 2003 Standard installation folder

I got the following in the message window:
 
System.IO.FileNotFoundException: Could not find file 'I:\Win2003\i386\wmp11temp\Fixes\Update\Update.inf'.
File name: 'I:\Win2003\i386\wmp11temp\Fixes\Update\Update.inf'
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options)
at System.IO.StreamReader..ctor(String path, Encoding encoding, Boolean detectEncodingFromByteOrderMarks, Int32 bufferSize)
at System.IO.StreamReader..ctor(String path, Encoding encoding, Boolean detectEncodingFromByteOrderMarks)
at Epsilon.Text.Ini.SimpleIniEditor..ctor(String filename)
at WMP11Slipstreamer.Backend.standardHotfixApply(String fixesFolder, Dictionary`2 hotfixFileDictionary)
at WMP11Slipstreamer.Backend.ApplyFixes()
at WMP11Slipstreamer.MainGUI.workerMethod(Object addonSettings)

Deleting "I:\Win2003\i386\wmp11temp"... Done!

The source being modified has not been damaged.
All changes have been successfully reverted.


This problem disappeared when using WindowsXP-KB941569-x86-ENU.EXE instead of WindowsServer2003-KB941569-x86-ENU.exe:).

Not exactly an urgent problem, but maybe something for the next release or something to point out for this oh so special KB941569.

#371
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,334 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
dutchman
as u know wmp11 was created ONLY for windows xp x32and x64 and vista.
for 2k3 they didnt .....so what i did is to adapt it a little bit so it works...only thing is that u need to run xp fixes for it not 2k3 fixes.

#372
tato

tato

    Newbie

  • Member
  • 14 posts
Is there a way to change the vanilla version and custom icon before nlite slipstream started? I want to use the tweaked version and Boooggy wmp11 icon.
Thanks

#373
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,334 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
tato
yes there is.....u use the slipstreamer as standalone before or after nlite.

#374
dencorso

dencorso

    Adiuvat plus qui nihil obstat

  • Super Moderator
  • 5,791 posts
  • OS:98SE
  • Country: Country Flag

Donator

Hello,

I'm trying to slipstream MP11 to Windows XP using the latest slipsteamer (this is the first time I use it) and both for English and Czech version I receive always this error:
[...]
Any idea what may be wrong?

Regards,

Petr


Hey, welcome back, Petr! :hello:
Your presence has been sorely missed!
Even if you've lost interest in Win 9x/ME (I sure hope you have not, though), please do visit us more often...
Your presence and your knowledgeable contributions are very important for us. You do rock! :thumbup
Best wishes!
Den.

#375
gauntlet123

gauntlet123

    Newbie

  • Member
  • 20 posts
I'm getting an error after I added a few new addons to make XP (x86, xp pro sp2) look more like Vista:

Posted Image

I've had no problems with the slipstreamer before, and got it after adding the following addons (nothing else changed):
Ricks_WindowsSidebarSP2_AlkyXP1.0_AddOn.7z
AIO_Vista_Theme_Addon_by_LUZR4LIFE.7z
ENG2ITA_WINFLIP_0421_ADDON.CAB
Gorki_AddOn_TrueTransparency_071207.cab
NR_EnergySS_Addon_1.2.cab
NR_StarterWalls_Addon.cab
Ricks_AIOVistaAeroCursors_AddOn_v7.07.03.rar
Ricks_AlkyVistaRTMApps_AddOn.rar
Ricks_GlassToasts_AddOn.rar
Ricks_QTTabAddressBar_AddOn_80114.rar
Ricks_TransBar1.4.2_AddOn.rar
Ricks_VistaRocketDock1.3.5_AddOn.rar
Ricks_VistaRTMBootSceen_KB944092.7z
Ricks_WindowsSidebar_CustomGadgets_AddOn_070911.rar
Ricks_WindowsSidebarStyler2.0.6_AddOn.rar

I searched and only found one person that's gotten a similar error, which was resolved by not integrating ToolTipFixer, but I don't use that addon so that's not the problem.

I haven't gone through the process of testing each addon one-by-one yet - was hoping this is a known issue or someone has experienced it before with these addons. If not, I'll test each addon and report back with which one if causing the problem.

Attached Files


Edited by gauntlet123, 02 March 2008 - 10:10 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN