Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

[RELEASE] Boooggy's WMP 11 direct integration solution

- - - - -

  • Please log in to reply
645 replies to this topic

#401
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,347 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
can u please attach txtsetup.sif?
thx


How to remove advertisement from MSFN

#402
Speeddymon

Speeddymon

    Advanced Member

  • Member
  • PipPipPip
  • 323 posts
  • Joined 04-September 06
It appears that the latest version of WMP11 Slipstreamer doesn't support some of the same flags that it used to. When adding MP11 Slipstreamer to nlite, and then starting the process, I get an error about usage, and then when clicking OK, the command line argument list appears. This is with 1.4.1. I could just be using it wrong, in which case, it would be great to know where the instructions are for how to properly use the slipstreamer with nlite.

#403
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,347 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
nothing changed and it works just fine for me.
Posted Image

#404
Mike89

Mike89

    Newbie

  • Member
  • 25 posts
  • Joined 23-November 03
  • OS:Windows 7 x64
  • Country: Country Flag

go for integrate wmp installer along with hotfixes after sp3 slipstream


I thought XP SP3 already included WMP 11 (and IE7). So why any further integrating be necessary since it includes WMP 11, IE7, and all up to date hotfixes (other than drivers or tweaks)?

Edited by Mike89, 22 March 2008 - 04:58 PM.

I7 3770K @ 4.4 gig (Noctua NH-U14S Heatsink), ASRock Z77 Extreme6, 16 Gigs (2x8) Corsair DDR3 1600, EVGA GTX 680 Signature 2, Acer P236H 23" (1920x1080), X-Fi Xtreme Gamer Pro, 2 DVD Burners, 2 WD 640 gig HDDs, WD 750 gig HDD (eSata), WD 1TB Black HDD, Sandisk 32 GB Readycashe SSD, Logitech Z-5500 5.1 Speaker System, Corsair TX750w PSU, HSPC Top Deck Tech Station, Windows 7 Pro x64


#405
Kurt_Aust

Kurt_Aust

    Master of trial, error & Google

  • Member
  • PipPipPipPip
  • 564 posts
  • Joined 26-April 07

I thought XP SP3 already included WMP 11 (and IE7). So why any further integrating be necessary since it includes WMP 11, IE7, and all up to date hotfixes (other than drivers or tweaks)?


Sorry to say, but XP SP3 includes neither IE7 nor WMP11, so you'll still have to integrate them with nLite and the WMP11 slipstreamer respectively.

Mind you, I'd have to agree it would be nice if they could put out 2 versions of the service pack, one vanilla (as currently planned) and one with the kitchen sink: IE7, WMP11, DirectX updates & .Net 2.0

#406
Mike89

Mike89

    Newbie

  • Member
  • 25 posts
  • Joined 23-November 03
  • OS:Windows 7 x64
  • Country: Country Flag
Dam, I got some bad info somewhere (forgot where I read it). Would have been nice for Microsoft to include WMP 11 and IE 7.

I guess Booggy's WMP 11 will be re-written a bit after SP3 comes out (since I would assume the hotfixes will not be needed)? Same goes for the IE 7 "NR_IE7en_Addon_1.1.0.7" pack I have now (for same reason).

Edited by Mike89, 23 March 2008 - 02:21 AM.

I7 3770K @ 4.4 gig (Noctua NH-U14S Heatsink), ASRock Z77 Extreme6, 16 Gigs (2x8) Corsair DDR3 1600, EVGA GTX 680 Signature 2, Acer P236H 23" (1920x1080), X-Fi Xtreme Gamer Pro, 2 DVD Burners, 2 WD 640 gig HDDs, WD 750 gig HDD (eSata), WD 1TB Black HDD, Sandisk 32 GB Readycashe SSD, Logitech Z-5500 5.1 Speaker System, Corsair TX750w PSU, HSPC Top Deck Tech Station, Windows 7 Pro x64


#407
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,347 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
i will not rewrite anything as long as sp3 doesnt contain any wmp 11 and its hotfixes.
sp3 contains wmp9.
and of course it would be nice that they were included ...but microsoft decided not to. so slipstreamer will be the same .....

Edited by boooggy, 23 March 2008 - 03:02 AM.


#408
Speeddymon

Speeddymon

    Advanced Member

  • Member
  • PipPipPip
  • 323 posts
  • Joined 04-September 06
As for the WMP11 updates not being needed, that would be incorrect as well, because the WMP11 updates are applied to WMP11 files, not Windows Files, so even with SP3, the WMP hotfixes will still not be applied. Not to mention that even once SP3 is RTM, it doesn't mean that people won't continue to integrate only SP2, since certain things that some people like (the Address Bar on the Taskbar) are going to be removed.

#409
BikinDutchman

BikinDutchman

    Member

  • Member
  • PipPip
  • 231 posts
  • Joined 11-January 07

x64: Setuperr.log errors:

Hi Boooggy,

I looked into this a little more, I know you hate x64 but please keep reading.

I had more luck using the Integrator BEFORE nLite.
-So I started with a fresh x64 SP2 and applied the integrator with all fixes.
-After that I applied nLite with the attached settings.

Afer installation WITH WinNT32 a had a functional system with only one line in setuperr.log:
Error:
Setup was unable to process some components because of the following error in section InstallWMP7 of information file wmp.inf:
The data is invalid.
***

I can probably live with that but do not know what it means.

And btw the "Play All" problem with x64 is now gone :thumbup

Attached Files



#410
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,347 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
i know about that error, dutchman and it will be fixed in next version.
x64 wmp integration is been a pain in the arse....hopefully this time it will work without errors.

Edited by boooggy, 23 March 2008 - 12:56 PM.


#411
krayzie358

krayzie358
  • Member
  • 5 posts
  • Joined 13-March 04
I would love to get this to work but it isn't could you help. Using a fresh copy of windows sp2 and it wouldn't slip in:

WMP11Slipstreamer v0.991
Detected source: Windows™ XP Professional SP2


System.Exception: Delta API failed to apply patch "_sfx_0010._p" to the file "update.exe". ---> System.ComponentModel.Win32Exception: Unknown error (0xc00e4102)
--- End of inner exception stack trace ---
at WMP11Slipstreamer.Backend.NativeExtractHotfix(String hotfixInstaller, String destinationPath)
at WMP11Slipstreamer.Backend.ExtractWMP11Installer()
at WMP11Slipstreamer.MainGUI.workerMethod(Object addonSettings)

Deleting "C:\XPCD\i386\wmp11temp"... FAILED!

An exception occurred while attempting to delete the temporary folder to revert the changes done to the source.

System.UnauthorizedAccessException: Access to the path '_sfx_.dll' is denied.
at System.IO.Directory.DeleteHelper(String fullPath, String userPath, Boolean recursive)
at System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive)
at WMP11Slipstreamer.ErrorForm..ctor(Exception ex, Boolean critical, String tempFolder, String osString, String hotfixList)


Thanks.

Tom

#412
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,347 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
krazie
please redownload the wmp 11 installer and before u add it to slisptreamer please check if installer is working.

#413
Frankenputer

Frankenputer
  • Member
  • 9 posts
  • Joined 23-August 07
I tried integrating WMP11 and the hotfixes and I get an error. If I just integrate WMP11 without the hotfixes, it integrates fine.
I get the following when doing the hotfixes. Sorry, I didn't try each one seperately to find the culprit(I did try it without the .msu file):

WMP11Slipstreamer v0.991
Detected source: Windows™ XP Professional SP2

Hotfixes:
Windows6.0-KB929399-x86.msu
windowsmedia11-kb928788-x86-intl.exe
windowsmedia11-kb929773-x86-intl.exe
windowsmedia11-kb932390-x86-intl.exe
windowsmedia11-kb933547-x86-intl.exe
windowsmedia11-kb935551-x86-intl.exe
windowsmedia11-kb935552-x86-intl.exe
windowsmedia11-kb939209-x86-intl.exe
WindowsMedia11-KB939683-x86-ENU.exe
windowsmedia11-kb942264-x86-intl.exe
windowsmedia11-kb944110-x86-intl.exe
windowsmedia11-kb944882-x86-intl.exe
windowsmedia11-kb946665-x86-intl.exe
WindowsXP-KB941569-x86-ENU.EXE

System.ComponentModel.Win32Exception: %1 is not a valid Win32 application
at Epsilon.Win32.Resources.ResourceEditor.throwWin32Exception()
at Epsilon.Win32.Resources.ResourceEditor.loadResourceLibrary()
at WMP11Slipstreamer.CM.GetCabData(String pathToSfxCab)
at WMP11Slipstreamer.Backend.NativeExtractHotfix(String hotfixInstaller, String destinationPath)
at WMP11Slipstreamer.Backend.standardHotfixApply(String fixesFolder, Dictionary`2 hotfixFileDictionary)
at WMP11Slipstreamer.Backend.ApplyFixes()
at WMP11Slipstreamer.MainGUI.workerMethod(Object addonSettings)

Deleting "F:\VRMPOEM_EN XP2C\i386\wmp11temp"... Done!

The source being modified has not been damaged.
All changes have been successfully reverted.



#414
n7Epsilon

n7Epsilon

    Currently Learning: C#, JavaScript, PHP

  • Member
  • PipPip
  • 156 posts
  • Joined 11-February 05
First of all a MSU file is an update for Windows Vista, not XP. There is a mixup of download links in one of the KB articles, all of the hotfixes should be exe files.

This is the reason of this error. Also if one of the hotfixes is corrupt (corrupt download) this will also happen.

Go into your hotfix folder and double-click on each hotfix (get rid of the MSU first and get the XP version) and the one that just flashes a console window without running is the culprit. Redownload it since it is corrupt and causing this issue.

In the next version I will build in a check for corrupted files.

#415
Frankenputer

Frankenputer
  • Member
  • 9 posts
  • Joined 23-August 07
Ahh, I see. I'vd been a tad busy. Instead of waiting for a response, I installed the OEM SP2C disc and then used SP3 RC refresh. I am testing at the moment and waiting on activating. I'll simply need to install WMP11 after. But, even if I hadn't had the error, I had a problem with my nlited discs, so I had to use the factory disc as stated previously(Of course, the nlite problem is immaterial here.).

#416
legendsohai

legendsohai

    Newbie

  • Member
  • 10 posts
  • Joined 14-February 08
Hi all,

im get an error during the WMP11 slipstreaming. Can anyone give me a hand on this error. Plz

Thanks very much

This is the bug report:
WMP11Slipstreamer v0.991
Detected source: Windows™ XP Professional SP2

Hotfixes:
windowsmedia11-kb928788-x86-intl.exe
WindowsMedia11-KB929399-v2-x86-INTL.exe
windowsmedia11-kb929773-x86-intl.exe
windowsmedia11-kb933547-x86-intl.exe
windowsmedia11-kb935551-x86-intl.exe
windowsmedia11-kb935552-x86-intl.exe
WindowsMedia11-KB936782-x86-ENU.exe
windowsmedia11-kb939209-x86-intl.exe
WindowsMedia11-KB939683-x86-ENU.exe
windowsmedia11-kb942264-x86-intl.exe
windowsmedia11-kb944110-x86-intl.exe
windowsmedia11-kb944882-x86-intl.exe
windowsmedia11-kb946665-x86-intl.exe
WindowsMedia-KB911564-x86-ENU.exe

System.IO.FileNotFoundException: Could not find file 'D:\Data\xp setup\i386\wmp11temp\Fixes\WM11\wmvcore.dll'.
File name: 'D:\Data\xp setup\i386\wmp11temp\Fixes\WM11\wmvcore.dll'
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileInfo.get_Length()
   at Epsilon.Win32.PeEditor..ctor(String pathToPe)
   at WMP11Slipstreamer.Backend.standardHotfixApply(String fixesFolder, Dictionary`2 hotfixFileDictionary)
   at WMP11Slipstreamer.Backend.ApplyFixes()
   at WMP11Slipstreamer.MainGUI.workerMethod(Object addonSettings)

Deleting "D:\Data\xp setup\i386\wmp11temp"...  Done!

The source being modified has not been damaged.
All changes have been successfully reverted.


#417
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,347 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
please go download the hotfixes from my site and then retry
kb911564 is a hotfix for wmp 6.4 and its not supported

#418
legendsohai

legendsohai

    Newbie

  • Member
  • 10 posts
  • Joined 14-February 08
Hi Booogy,

thx for your reply!!!

I am very appreciate to your helps.

my problem has been solved easily by followed your instructions

you are helping me a lot.

thx very much

#419
odyssey5

odyssey5

    foobar2000 poweruser

  • Member
  • 31 posts
  • Joined 11-November 05
Why is the menubar showing on my integrated WMP 11?

Process:
1. nLite'd
2. WMP integrated with Tweak option

(I just read that it should be the other way, but first time I did that, it didn't work - Maybe because I removed the WMP10 component with nlite?)

Which tweaks are applied with tweak option?

#420
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,347 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
first of all u should not remove any wmp componentsw with nlite.
second the tweaks are toooo many to be enumerate. anyhow....we are working to separate the tweaks which will appear in one of the next versions.
if u dont want the menu bar choose vanila.

#421
Outbreaker

Outbreaker

    Advanced Member

  • Member
  • PipPipPip
  • 300 posts
  • Joined 08-August 07
  • OS:Windows 7 x86
  • Country: Country Flag
HI :)

Do i need too include all this Updates also if i have SP3 slipstreamed into the CD ?
If i install WMP11 without Updates and if i go to Windows Update Center and check for updates then i only see one update KB941569.

#422
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,347 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
as long as i know....sp3 doesnt contain wmp 11 fixes.
also sp3 its not yet public so i guess that wu doesnt work fully.
so my recomandation is to include all fixes.

#423
LordWarlock

LordWarlock

    Junior

  • Member
  • Pip
  • 68 posts
  • Joined 11-September 05
Can someone post a working link for KB946665 XP x86, all I get from MS is a file with correct size, but full of 00 (if opened in Hex editor).

#424
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,347 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag

Can someone post a working link for KB946665 XP x86, all I get from MS is a file with correct size, but full of 00 (if opened in Hex editor).


can u please upload tis fix tome?
yes i needed corupted.....
also contact me on pm....

#425
LM2007

LM2007

    Newbie

  • Member
  • 14 posts
  • Joined 29-April 08
When i press integrate i get a


the following source type is not supported:

Windows XP Professional"

what happens?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users