Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

[RELEASE] Boooggy's WMP 11 direct integration solution

- - - - -

  • Please log in to reply
645 replies to this topic

#451
dazzlee

dazzlee

    Newbie

  • Member
  • 22 posts
  • Joined 15-November 06
Did a integrate without any hotfixes, integration gone smoothly, I think thers a problem with a Hotfix you specified....

But not yet tested the installation,,,,

Edit1:

Did integrate WMP11 with all Hotfixes except "windowsmedia11-kb946665-x86-intl.exe",,, integraton gone smoothly

when this hotfix is added, the error pops up....

Edited by dazzlee, 12 May 2008 - 10:38 AM.



How to remove advertisement from MSFN

#452
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,347 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
i guess u have 946665 corrupted. that fix is corupted from microsoft server...so try redownload. and after u did it...run it to be sure its working.

#453
dazzlee

dazzlee

    Newbie

  • Member
  • 22 posts
  • Joined 15-November 06

i guess u have 946665 corrupted. that fix is corupted from microsoft server...so try redownload. and after u did it...run it to be sure its working.

NO booogy, i downloaded the latest hotfix, after they fixed,,,

I think, being its a new hotfix, they compressed with the new cabinet maker, so its unable to open by the cab in Windows 2000 while extracting in 2K Environment...... its only my guess!!!

#454
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,347 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
dazz
i tried it in 2k enviroment including 946665 and all went fine.
i used win2k with sp5.

#455
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,347 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
new version!
change log for 1.2:
1. Complete rewrite of ini file editor, massive file editing speed increase (SimpleIniEditor renamed to IniParser)
2. Complete rewrite of cabinet.dll interface, problems with COMODO Defense+ fixed, now x64 compatible (can be compiled and work with 64-bit cabinet.dll)
3. Complete separation of Backend from user interface, switch to events. Cross-thread dialogs now open with the main window as its owner correctly.
4. Cleaned up Backend error handling.
5. Removal of embedded uxtheme.dll and msobmain.dll hotfixes. Slipstreamer will break unattended and display a warning if it finds that uxtheme or msobmain need updating, integrate before running wmp11slip to avoid this.
* integrate those fixes before running the slipstreamer to avoid this.
6. Updated to support Windows XP Service Pack 3 (automatically applies wbem fix if required)
7. Fixed issues on x64 WMP11
8. Fixed issue presented here

Edited by boooggy, 12 May 2008 - 11:04 PM.


#456
eryen

eryen

    Junior

  • Member
  • Pip
  • 91 posts
  • Joined 23-December 05
I have an error.

WMP11Slipstreamer v1.2.0.0
Detected source: Windows™ XP Professional SP3

Epsilon.Parsers.IniParser+Exceptions+MalformedSectionHeaderException: Malformed section header after []: ([

Deleting "C:\WinXPSP3\i386\wmp11temp"... Done!

The source being modified has not been damaged.
All changes have been successfully reverted.


I atteched Turkish wmp.inf and update.inf files.
Maybe u my want to look at it.



ADD:
Tested with English WMP11 on my Turkish Windows XP. (To see wmp11.inf and update.inf)
And still same error.
So i think that is not because of WMP files.
Probably Windows XP files.

I may attach all files u may want.

Attached Files


Edited by eryen, 13 May 2008 - 03:52 AM.


#457
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,347 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
eryen
can u please attach wmp.inf from your untoched windows xp?
thx

and please attach also the full report that slipstreamer throw.

Edited by boooggy, 13 May 2008 - 04:00 AM.


#458
Kelsenellenelvian

Kelsenellenelvian

    WPI Guru

  • Developer
  • 8,820 posts
  • Joined 18-September 03
  • OS:Windows 7 x64
  • Country: Country Flag

I have an error.

WMP11Slipstreamer v1.2.0.0
Detected source: Windows™ XP Professional SP3

Epsilon.Parsers.IniParser+Exceptions+MalformedSectionHeaderException: Malformed section header after []: ([

Deleting "C:\WinXPSP3\i386\wmp11temp"... Done!

The source being modified has not been damaged.
All changes have been successfully reverted.


I atteched Turkish wmp.inf and update.inf files.
Maybe u my want to look at it.



ADD:
Tested with English WMP11 on my Turkish Windows XP. (To see wmp11.inf and update.inf)
And still same error.
So i think that is not because of WMP files.
Probably Windows XP files.

I may attach all files u may want.



Is your source pre-modified AT ALL?

Did you remove both wmp versions 9 + 6.4 with nLite?

#459
eryen

eryen

    Junior

  • Member
  • Pip
  • 91 posts
  • Joined 23-December 05
That's all, nothing more.

WMP11Slipstreamer v1.2.0.0
Detected source: Windows™ XP Professional SP3

Epsilon.Parsers.IniParser+Exceptions+MalformedSectionHeaderException: Malformed section header after []: ([

Deleting "C:\WinXPSP3\i386\wmp11temp"... Done!

The source being modified has not been damaged.
All changes have been successfully reverted.



Nothing removed.
Just added these files with HFSLIP on original Windows XP SP3 source

msxml4.msi
rootsupd.exe
Windows-KB890830-V1.40.exe
WindowsUpdateAgent30-x86.exe
WindowsXP-KB905474-X86-TRK.exe


Older WMP11Slipstreamer works after these files added.

Attached Files

  • Attached File  wmp.inf   56.84KB   5 downloads

Edited by eryen, 13 May 2008 - 04:30 AM.


#460
eryen

eryen

    Junior

  • Member
  • Pip
  • 91 posts
  • Joined 23-December 05
Hımmm...

I guess i found it.
HFSLIP modifies WBEMOC.INF file.
Deletes napclientprov.mof and napclientschema.mof entries in it.

WMP11Slipstreamer can not read new file anymore.
I just opened that file. ReSaved. Compressed. Replaced in source.
Than WMP11 Slipstreamer works.


Is this HFSLIP's fault?
But still 0.99i can slipstream in same source.

I feel so stupid now.
Going to complain TomCat :P

Attached Files


Edited by eryen, 13 May 2008 - 05:11 AM.


#461
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,347 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
i dont get why hfslip deletes those entries.....
o well....good u found it and thx for reporting...

0991 doesnt edit that file....so thats why no error....

#462
eryen

eryen

    Junior

  • Member
  • Pip
  • 91 posts
  • Joined 23-December 05
In fact, i didnot know that changes.

I realized that after completely folder compare.

Edited by eryen, 13 May 2008 - 06:57 AM.


#463
n7Epsilon

n7Epsilon

    Currently Learning: C#, JavaScript, PHP

  • Member
  • PipPip
  • 156 posts
  • Joined 11-February 05
The original wbemoc.inf is encoded as UCS-2 Little Endian (UTF16-LE) with the byte-order-mark at the beginning of the file.

It seems that hfslip when saving the file, strips the byte-order-mark, so when wmp11slip reads it. It thinks it is reading an ANSI file. This is the reason on the error.

This is HFSLIP problem, not slipstreamer problem.

#464
dazzlee

dazzlee

    Newbie

  • Member
  • 22 posts
  • Joined 15-November 06

dazz
i tried it in 2k enviroment including 946665 and all went fine.
i used win2k with sp5.


Oh, i did in Win2kSP4 with Onepiece Updatepack,,,i'll try your new version later... now i changed to XP...

thanks!!

#465
jdmaynard

jdmaynard
  • Member
  • 1 posts
  • Joined 15-May 08
I got the following error trying to slip WMP11 into WinXP-SP3. Any suggestions???

Thanks

DOug

-----------------------------------------------------------------------------------------------------
WMP11Slipstreamer v1.2.0.0
Detected source: Windows™ XP Professional SP3

System.IO.IOException: The process cannot access the file 'D:\WinXP_SP3\i386\wmp11temp\extracted\update' because it is being used by another process.
at System.IO.Directory.DeleteHelper(String fullPath, String userPath, Boolean recursive)
at System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive)
at Epsilon.IO.FileSystem.DeleteFileOrFolder(String FileOrFolder)
at WMP11Slipstreamer.Backend.SlipstreamWMP11()
at WMP11Slipstreamer.MainForm.WorkerMethod(Object workerParam)

Unfortunately, the error occurred during the critical process of overwriting files in the "i386" folder. This source is now corrupt, please use a fresh new source for subsequent windows setup installations and modifications.

Temporary folder: "D:\WinXP_SP3\i386\wmp11temp"
------------------------------------------------------------------------------------------------------

#466
0d14r3

0d14r3

    Member

  • Member
  • PipPip
  • 195 posts
  • Joined 12-September 06
1 - Try use SEARCH
2 - Post your problem here: http://www.msfn.org/...egr-t90635.html , it ís Release post from booggy Slipstreamer

Saludos!

0d

#467
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,347 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
and please add the full error report....

Edited by boooggy, 16 May 2008 - 01:08 PM.


#468
LES!

LES!
  • Member
  • 4 posts
  • Joined 12-August 05
After reverting to WMP11slipstreamer v 0.991 intergeration worked. I would perfer to use newer version. Any help is appreciated.
LES

BUG Report

WMP11Slipstreamer v1.2.0.0
Detected source: Windows™ XP Professional SP3

Hotfixes:
KB941569.EXE
KB911564.exe
KB929773.exe
KB932390.exe
KB933547.exe
KB935551.exe
KB935552.exe
KB936782.exe
KB939683.exe

System.NotSupportedException: The given path's format is not supported.
at System.Security.Util.StringExpressionSet.CanonicalizePath(String path, Boolean needFullPath)
at System.Security.Util.StringExpressionSet.CreateListFromExpressions(String[] str, Boolean needFullPath)
at System.Security.Permissions.FileIOPermission.AddPathList(FileIOPermissionAccess access, AccessControlActions control, String[] pathListOrig, Boolean checkForDuplicates, Boolean needFullPath, Boolean copyPathList)
at System.Security.Permissions.FileIOPermission..ctor(FileIOPermissionAccess access, String[] pathList, Boolean checkForDuplicates, Boolean needFullPath)
at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite)
at WMP11Slipstreamer.Backend.CompressFiles()
at WMP11Slipstreamer.Backend.SlipstreamWMP11()
at WMP11Slipstreamer.MainForm.WorkerMethod(Object workerParam)

Deleting "C:\1nlite\XP_CD\i386\wmp11temp"... Done!

The source being modified has not been damaged.
All changes have been successfully reverted.

#469
BikinDutchman

BikinDutchman

    Member

  • Member
  • PipPip
  • 231 posts
  • Joined 11-January 07
Your hotfixes are wrong, goto the slipstreamer web-site and fix.

Edited by boooggy, 16 May 2008 - 01:03 PM.


#470
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,347 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
like dutchman said....KB911564.exe is a hotfix for wmp6.4 and its not supported by slipstreamer.

Edited by boooggy, 16 May 2008 - 01:03 PM.


#471
premier4ever

premier4ever

    Newbie

  • Member
  • 25 posts
  • Joined 16-March 08
WMP11Slipstreamer v1.2.0.0
Detected source: Windows™ XP Professional SP2

Hotfixes:
windowsmedia11-kb928788-x86-intl.exe
windowsmedia11-kb929399-v2-x86-intl.exe
windowsmedia11-kb929773-x86-intl.exe
windowsmedia11-kb932390-x86-intl.exe
windowsmedia11-kb933547-x86-intl.exe
windowsmedia11-kb935551-x86-intl.exe
windowsmedia11-kb935552-x86-intl.exe
windowsmedia11-kb939209-x86-intl.exe
WindowsMedia11-KB939683-x86-ENU.exe
windowsmedia11-kb942264-x86-intl.exe
windowsmedia11-kb944110-x86-intl.exe

System.IO.FileNotFoundException: Could not load file or assembly 'System.Xml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.
File name: 'System.Xml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'
at WMP11Slipstreamer.Backend.ParseXmlAndVerifyDestinationOs(String xmlPath)
at WMP11Slipstreamer.Backend.ExtractWMP11Installer()
at WMP11Slipstreamer.Backend.SlipstreamWMP11()
at WMP11Slipstreamer.MainForm.WorkerMethod(Object workerParam)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].


Deleting "E:\XPSP3 Test\i386\wmp11temp"... Done!

The source being modified has not been damaged.
All changes have been successfully reverted.
Find a way to my heart, and I will always be with you

#472
n7Epsilon

n7Epsilon

    Currently Learning: C#, JavaScript, PHP

  • Member
  • PipPip
  • 156 posts
  • Joined 11-February 05
Did you install the special nLite Runtime Components package ?
If so, then that is the problem, remove it and reinstall .NET 2.0

If you didn't, then your .NET 2.0 installation has been modified by something else
that damaged it, uninstall .NET 2.0 and reinstall it.

#473
anonim1979

anonim1979

    Newbie

  • Member
  • 19 posts
  • Joined 15-September 04
1.2
(I'm posting it in 3 places so it won't be overlooked)

I dont think that second instance of:
napclientprov.mof
napclientschema.mof
should be modified like the first

I think that this part should stay as it is:


[WBEM.SYSTEMMOFS]
....
CmdEvTgProv.mof
dgnet.mof
whqlprov.mof ; wmi provider for whql to get driver signing info. a-kjaw
ieinfo5.mof
rsop.mof
rsop.mfl
wscenter.mof
napclientprov.mof
napclientschema.mof


The first is in COPY files section and is indeed missing 8.3 filename. So the instaler dont know from what 8.3 file copy that long filename files.

But second is in section that doesn't copy files and there are other not 8.3 names:
CmdEvTgProv.mof
there is no need to add references for source files in this section.


checked:
c:\WINDOWS\system32\wbem\Logs\setup.log
c:\WINDOWS\system32\wbem\Logs\mofcomp.log

Modified 2 instances (like 1.2 slipstreamer do)

(Tue May 20 05:34:31 2008): Beginning Wbemupgd.dll Registration
(Tue May 20 05:34:31 2008): Current build of wbemupgd.dll is 5.1.2600.5512 (xpsp.080413-2108)
(Tue May 20 05:34:31 2008): Beginning Core Upgrade
(Tue May 20 05:34:31 2008): ERROR: GetStandardMofs failed to locate file C:\WINDOWS\system32\WBEM\napclientprov.mof,napprov.mof.
(Tue May 20 05:34:31 2008): ERROR: GetStandardMofs failed to locate file C:\WINDOWS\system32\WBEM\napclientschema.mof,napschem.mof.
(Tue May 20 05:34:31 2008): Beginning MOF load
(Tue May 20 05:34:31 2008): Processing C:\WINDOWS\system32\WBEM\cimwin32.mof




One (like I recomended)

(Tue May 20 03:48:43 2008): Beginning Wbemupgd.dll Registration
(Tue May 20 03:48:43 2008): Current build of wbemupgd.dll is 5.1.2600.5512 (xpsp.080413-2108)
(Tue May 20 03:48:43 2008): Beginning Core Upgrade
(Tue May 20 03:48:43 2008): Beginning MOF load
(Tue May 20 03:48:43 2008): Processing C:\WINDOWS\system32\WBEM\cimwin32.mof


And they show properly in
c:\WINDOWS\system32\wbem\Logs\mofcomp.log

C:\WINDOWS\system32\WBEM\napclientprov.mof
(Tue May 20 03:49:25 2008.1242797) : Finished compiling file:C:\WINDOWS\system32\WBEM\napclientprov.mof
(Tue May 20 03:49:25 2008.1242807) : Przetwarzanie pliku MOF: C:\WINDOWS\system32\WBEM\napclientschema.mof
(Tue May 20 03:49:25 2008.1242857) : Finished compiling file:C:\WINDOWS\system32\WBEM\napclientschema.mof



See page 22 for more info.

#474
Kelsenellenelvian

Kelsenellenelvian

    WPI Guru

  • Developer
  • 8,820 posts
  • Joined 18-September 03
  • OS:Windows 7 x64
  • Country: Country Flag
@ - anonim1979:

What is your problem? and your proposal?

I can't understand your post.

#475
anonim1979

anonim1979

    Newbie

  • Member
  • 19 posts
  • Joined 15-September 04
The modifications made by WMP11Splipstreamer 1.2 to wbemoc.inf in [WBEM.SYSTEMMOFS] section are unnesesarty and you can see this in log files;
ERROR: GetStandardMofs failed to locate file C:\WINDOWS\system32\WBEM\napclientprov.mof,napprov.mof.
problematic

More on that SP3 fix here:
http://www.ryanvm.ne...pic.php?p=76404
I wrote about that and linked on 22nd page of this thread.

Simply my recomendation was overlooked so this time I posted it in all 3 threads ;)
It's bug report for developers of WMP11 Splipstreamer - they will know what it is about.

Edited by anonim1979, 19 May 2008 - 11:15 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users