Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

[RELEASE] Boooggy's WMP 11 direct integration solution

- - - - -

  • Please log in to reply
645 replies to this topic

#501
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,332 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
new version changelog 1.2.5.0:
- Regression fix from path handling improvements. This affected the case when we are copying files that overwrite in the standard architecture directory causing a crash with "Path format not supported".
- Fixed adding updated wmp drivers to driver32.cab instead of driver.cab
- Migrated code to subversion.


How to remove advertisement from MSFN

#502
kayfam

kayfam
  • Member
  • 4 posts
  • Joined 17-July 06
Thanks boooggy for the update and sorry about not getting back to you on my prior post. Real life got in the way and no time for browsing the forum :}

#503
eddie11013

eddie11013

    Member

  • Member
  • PipPip
  • 177 posts
  • Joined 15-February 07
@Boooggy

A “for what its worth” comment. A made a new nlited DVD, with the latest 1.4.5.5?, windows xp pro + sp3 + various add-on’s, component removal, driver integration etc. Everything worked like a charm, however, it turned out that I accidentally deleted the windows media player 11 installer from my hot fixes and also hadn’t installed your slipstreamer. Therefore, when I went to windows updates, I was presented with the option of installing WMP 11. Installed same, and “finally”, getting to the point, I only had to install “one” critical update, the one we have always known, KB941569. So, again, maybe worth noting, no “other” updates seem to be necessary. Maybe it’s a “SP3” thing. I don’t know. Of course, without your slipstreamer, I now have four programs show up in my “add and remove programs” that weren’t there before when using your ‘slipstreamer’. Namely: Microsoft Compression Client Pack 1.0 for Windows XP, Microsoft User-Mode Driver Framework Feature Pack 1.0, Windows Media Format 11 Runtime and Windows Media Player 11. I assume, using your slipstreamer, these are “all” installed they just don’t show up in “Add and Remove” because of the “slipstreaming”.
That’s it. The end.
Hope this helps. Great program, by the way, thanks for everything.
Eddie

#504
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,332 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
yes eddie the wmp 11 installer is made from 4 individual parts. so u will get also the uninstall option for this parts. when u use the slipstreamer those uninstall is not created.
also the hotfixes that appears on my site are also neeeded even if they dont show up on wu/mu

Edited by boooggy, 09 June 2008 - 01:34 PM.


#505
pppx00

pppx00

    Junior

  • Member
  • Pip
  • 80 posts
  • Joined 02-October 04
http://www.boooggy.org/slipstreamer/ not working.

EDIT. Now is working, sorry :P.

Edited by pppx00, 10 June 2008 - 08:59 PM.


#506
JimVR4

JimVR4
  • Member
  • 2 posts
  • Joined 03-June 08
Thanks boooggy!

My integration of Windows XP Pro with SP3, IE7, and WMP11 works flawlessly!

#507
sumitam

sumitam
  • Member
  • 6 posts
  • Joined 10-June 08
hey can anyone help am getting this error

WMP11Slipstreamer v1.2.5.0
Detected source: Windows™ XP Professional SP3

System.ComponentModel.Win32Exception: The system cannot find the file specified
at Epsilon.Win32.Resources.ResourceEditor.ThrowWin32Exception()
at Epsilon.Win32.Resources.ResourceEditor.LoadResourceLibrary()
at WMP11Slipstreamer.CM.GetCabStream(String pathToSfxCab)
at WMP11Slipstreamer.Backend.NativeExtractHotfix(String hotfixInstaller, String destinationPath)
at WMP11Slipstreamer.Backend.ExtractWMP11Installer()
at WMP11Slipstreamer.Backend.SlipstreamWMP11()
at WMP11Slipstreamer.MainForm.WorkerMethod(Object workerParam)

Deleting "H:\WINXPSP2pure\i386\wmp11temp"... Done!

The source being modified has not been damaged.
All changes have been successfully reverted.

#508
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,332 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
please add the full report

#509
n7Epsilon

n7Epsilon

    Currently Learning: C#, JavaScript, PHP

  • Member
  • PipPip
  • 147 posts
  • Joined 11-February 05
What did you choose in the wmp11 installer box ? What is the path to the installer ?

#510
sumitam

sumitam
  • Member
  • 6 posts
  • Joined 10-June 08
thanks for quick reply

ok am explaining the whole thing that i did


location of WMP11Slipstreamer.exe H:\WMP Spl\WMP11Slipstreamer.exe

path to media player 11 H:\wmp11-windowsxp-x86-enu.exe
path to windows source H:\WINXPSP2pure
after this when i press intergate
it shows

WMP11Slipstreamer v1.2.5.0
Detected source: Windows™ XP Professional SP3

System.ComponentModel.Win32Exception: The system cannot find the file specified
at Epsilon.Win32.Resources.ResourceEditor.ThrowWin32Exception()
at Epsilon.Win32.Resources.ResourceEditor.LoadResourceLibrary()
at WMP11Slipstreamer.CM.GetCabStream(String pathToSfxCab)
at WMP11Slipstreamer.Backend.NativeExtractHotfix(String hotfixInstaller, String destinationPath)
at WMP11Slipstreamer.Backend.ExtractWMP11Installer()
at WMP11Slipstreamer.Backend.SlipstreamWMP11()
at WMP11Slipstreamer.MainForm.WorkerMethod(Object workerParam)

Deleting "H:\WINXPSP2pure\i386\wmp11temp"... Done!

The source being modified has not been damaged.
All changes have been successfully reverted.

am attaching the image to the error please have look to that.
Attached File  New.jpg   177.76KB   9 downloads
Please tell me what mistake am doing

#511
n7Epsilon

n7Epsilon

    Currently Learning: C#, JavaScript, PHP

  • Member
  • PipPip
  • 147 posts
  • Joined 11-February 05
Can you please tell me the md5 of the wmp11 installer that you have ?

If it is not: D1A08DAB82A85BD18CFD54C70EE05671, please upload it somewhere and post a link because I want to look at the wmp installer you are using (it maybe corrupt in such a way that I am not detecting it).

#512
sumitam

sumitam
  • Member
  • 6 posts
  • Joined 10-June 08

Can you please tell me the md5 of the wmp11 installer that you have ?

If it is not: D1A08DAB82A85BD18CFD54C70EE05671, please upload it somewhere and post a link because I want to look at the wmp installer you are using (it maybe corrupt in such a way that I am not detecting it).



what is md5 & where should i get it in the installer

#513
radix

radix

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 755 posts
  • Joined 08-February 07
  • OS:Windows 8 x64
  • Country: Country Flag

what is md5 & where should i get it in the installer

Download and install Hash Tab 2.0.9.
Then right click on WMP11 installer->Properties->File Hashes

#514
sumitam

sumitam
  • Member
  • 6 posts
  • Joined 10-June 08

what is md5 & where should i get it in the installer

Download and install Hash Tab 2.0.9.
Then right click on WMP11 installer->Properties->File Hashes


thanks buddy

#515
sumitam

sumitam
  • Member
  • 6 posts
  • Joined 10-June 08
ok this is what i get in file hashes of my wmp installer

CRC32: A87E8A6A
MD5: 4A3DE150EF717826A3843278509CE7B9
SHA-1: 126607377E36057C0E80CB4C2A2458B6BB6E8678

#516
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,332 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
new version out
changelog here

#517
TranceEnergy

TranceEnergy

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 963 posts
  • Joined 23-March 06

new version out
changelog here


Looking at the changelog most of it tells me, who isnt a programmer, absolutely nothing.
I've just spent quite some time fixing the files to not install portable devices/drm/network sharing service.
Is there any chance such tweak/removal options will ever be added to this program?

#518
lol69002

lol69002
  • Member
  • 9 posts
  • Joined 01-March 06
Bonjour a tous et merci pour ce fabuleux petit soft

report bug on v1.3.0.1

"satellite assembly error"
localizer culture mismatch: switching back to default culture

Attached Files


Edited by lol69002, 17 June 2008 - 11:56 AM.


#519
n7Epsilon

n7Epsilon

    Currently Learning: C#, JavaScript, PHP

  • Member
  • PipPip
  • 147 posts
  • Joined 11-February 05
@TranceEnergy: I am working on this (customizations), this should arrive in a 2.0 release, most of the changes are (as you have noticed) not really affecting the resultant wmp11 install, these were cosmetic fixes and localization changes, the INFs were not touched or changed from last version.

@lol69002: I'll post a quick fix for that soon. Stupid mistake from my part (and couldn't test because using english xp with english regional settings)....

#520
TranceEnergy

TranceEnergy

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 963 posts
  • Joined 23-March 06

@TranceEnergy: I am working on this (customizations), this should arrive in a 2.0 release, most of the changes are (as you have noticed) not really affecting the resultant wmp11 install, these were cosmetic fixes and localization changes, the INFs were not touched or changed from last version.

@lol69002: I'll post a quick fix for that soon. Stupid mistake from my part (and couldn't test because using english xp with english regional settings)....


That is awesome!!!
I just realized i dont need any of the files in wmp11.cab, so deleted it, stupid thing is i then also have more to update in txtsetup file.
This made my day, i'm getting a beer, wish i could pass one along. Cheers!

#521
lol69002

lol69002
  • Member
  • 9 posts
  • Joined 01-March 06

@TranceEnergy: I am working on this (customizations), this should arrive in a 2.0 release, most of the changes are (as you have noticed) not really affecting the resultant wmp11 install, these were cosmetic fixes and localization changes, the INFs were not touched or changed from last version.

@lol69002: I'll post a quick fix for that soon. Stupid mistake from my part (and couldn't test because using english xp with english regional settings)....


thx for this quikly release, 1.3.0.2 works fine

merci

#522
twig123

twig123

    Advanced Member

  • Member
  • PipPipPip
  • 362 posts
  • Joined 02-October 05
The /output: switch is no longer working in v1.3.0.2 ...

using the /output:"Normal" option returns the below error with the =Value of '0'
using the /output:"Tweaked" option returned the below error with the =Value of '1'
Unhandled Exception in UI Thread

System.ArgumentOutOfRangeException: Invalid Argument=Value of '0' is not valid for 'SelectedIndex'.
Parameter name: SelectedIndex
  at System.Windows.Forms.ComboBox.set_SelectedIndex(Int32 value)
  at WMP11Slipstreamer.MainForm.ProcessParameters(String installer, String winsource, String hotfixes, String output, string customicon, Boolean nocats, Boolean slipstream, String customIconPath)
  at WMP11Slipstreamer.MainForm..ctor(String installer, String winsource, String hotfixes, String output, String customicon, Boolean nocats, Boolean slipstream, Boolean close, String customIconPath)
  at WMP11Slipstreamer.EntryPoint.Main(String[] args)
If I remove the /output switch from my batch, WMP11Slipstreamer opens with all of my settings (with no output type selected), however, I can select the output type and click integrate and the slip finishes.

I have not found any issues with manual Integration.

Edited by twig123, 17 June 2008 - 07:42 PM.


#523
n7Epsilon

n7Epsilon

    Currently Learning: C#, JavaScript, PHP

  • Member
  • PipPip
  • 147 posts
  • Joined 11-February 05
Issue confirmed, this is due to my localizing efforts moved the code that processes parameters before the code that fills the output type box, leading to this issue.

It will be fixed in next version.

#524
boooggy

boooggy

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,332 posts
  • Joined 27-February 05
  • OS:Windows 8.1 x64
  • Country: Country Flag
twig
please try new version

#525
Bossman7

Bossman7
  • Member
  • 4 posts
  • Joined 29-February 08
Works fantastic, many thanks for all your constant hard work ;)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users