Sign in to follow this  
Followers 0
steviewonder

After making cd with Vlite, how can i execute wpi?

4 posts in this topic

I've made my Vista installation down to 662 megs

and want to run wpi after install completes, anyone know how?

Or should i ask this in WPI section?

0

Share this post


Link to post
Share on other sites

Easiest way to accomplish that should be mounting the install.wim with imagex.exe. Changeinto \WINDOWS\SETUP in your mountpoint and create the directory "Scripts".

Place a .cmd file there called setupcomplete.cmd and call WPI from there.

Be careful with the old CD-ROM/DVD-ROM detection code that looks for WIN51IP though, accessing a none-existant device in Vista results in a error messagebox that halts the install process. I might have the workaround I used somewhere still. If I remember correctly I checked with the "vol" command if a drive-letter is a valid volume by processing the errorcode that vol returned...

Or add WPI to a directory in the install.wim and thenn call it with %PROGRAMFILES%\WPI\WPI.EXE or something like that

0

Share this post


Link to post
Share on other sites

Or add WPI to a directory in the install.wim and thenn call it with %PROGRAMFILES%\WPI\WPI.EXE or something like that

I like that idea, I've already run into the halt error, thanks will

give it a go. :thumbup

0

Share this post


Link to post
Share on other sites

YW..

Edited by Clint
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.