Tihiy

Windows 2000 Revolutions Pack

194 posts in this topic

This program allows your Windows 2000 to display 32-bit icons.

32-bit icons were introduced in Windows XP. They're improving experience with high-color smooth images with alpha channel (i.e. shadow).

It wasn't possible to view them properly in previous Windows versions.

2 years ago, i've started Windows 98 Revolutions Pack project, which allowed Windows 98 to display those icons (and later visual themes, new system applets, improved shell experience and so on).

Now i'm presenting Windows 2000 Revolutions Pack.

I hope it isn't late and some people like&use Win2000.

So, it Requires:

- Windows 2000, SP4 & IE6 preffered (not tested with IE5)

- 32-bit video mode. If your videocard does not support it, you're out of luck.

Installing RP 2.01 [attached to this post]:

- Extract/Run setuprp.exe [safe mode recommended]

- Reboot

Uninstall:

- In Add/Remove programs

Pros:

- does not patch system files;

- consumes extremely little amounts of memory;

- easy to install/slipstream.

Example: (with Vista Icon Pack 3.0 applied)

exampleon6.th.png

How to force application to display 32-bit image lists:

This workaround cures black shadows or discolored images in programs which were written unaware of 32-bit icons with Windows 2000.

Create "your program.exe.32bitimgl" file for your program.exe in the folder this exe resides. Viola!

You can also use this trick instead of "256-color tray patch" for explorer.exe, however, this isn't the right way. I think.

RPL2k202.zip

Edited by Tihiy
0

Share this post


Link to post
Share on other sites

This is a really nice work, I don't know if i'm crazy but it seems that the alpha channel thing works better on Windows 2000.

0

Share this post


Link to post
Share on other sites

Good work!

*rushes to download dll*

Now could someone start upgrading the kernel?

0

Share this post


Link to post
Share on other sites

nice tihy!

you impress me time and time again. many people thougt that 32bit icons in 2000 were impossilbe. is this the first step of a windows 2000 revolutions pack? are you going to release some other versions?

0

Share this post


Link to post
Share on other sites

Mostly working well here, Tihiy, though I should note that I registered it from a different directory at first and that didn't work - only when I did it from winnt/system32 as suggested.

I've found one small bug: if you look at the attached picture the icons appear correctly within the options window (see Bold, Italics, Underline top right) but are not displayed correctly in a toolbar (middle left), where the alpha does not appear to be applied. Is this something that can be fixed or a limitation on where it can be used?

Thanks!

post-69830-1171807658_thumb.jpg

0

Share this post


Link to post
Share on other sites

I haven't used Miranda for a while. Can you please tell me which plug-ins/smilies i should install?

0

Share this post


Link to post
Share on other sites

The window where the problem occurs is chat.dll, it's used for multi-user stuff like IRC and MSN chatrooms.

In case you need it, the bit that's displayed correctly is a plugin called IcoLib (Icon Library Manager), though if you use a development version rather than the stable version you don't need a plugin because it's built in.

HTH!

0

Share this post


Link to post
Share on other sites

Here's the problem:

http://miranda.svn.sourceforge.net/viewvc/...c?revision=4796

hImageList = ImageList_Create(GetSystemMetrics(SM_CXSMICON),GetSystemMetrics(SM_CYSMICON),IsWinVerXPPlus()? ILC_COLOR32 | ILC_MASK : ILC_COLOR16 | ILC_MASK,0,3);
hIconsList = ImageList_Create(GetSystemMetrics(SM_CXSMICON),GetSystemMetrics(SM_CYSMICON),IsWinVerXPPlus()? ILC_COLOR32 | ILC_MASK : ILC_COLOR16 | ILC_MASK,0,100);

This plug-in doesn't imagine itself Windows <XP with 32-bit icon support!

So, possible solutions:

* Ask author for change

- Lie to Miranda what we're running on Windows XP

- Force Miranda to get only 32-bit imagelists

0

Share this post


Link to post
Share on other sites

Well, i've contacted author about that and managed to fix (workaround) this in version 1.1 (first post)

Create empty file programname.exe.32bitimgl (where programname.exe resides) to force your programname to work with 32-bit images.

With that (miranda32.exe.32bitimgl), Miranda displays 32-bit icons everywhere flawlessly! :thumbup

About upgrading: you should uninstall (unregister) rpl2k.dll first. Then reboot, replace dll with newer version, register new version, and reboot again (or logoff).

0

Share this post


Link to post
Share on other sites

I suspect this would be the case with Miranda and Win98SE + Revolutions Pack too, as I got a similar behaviour when I had that combination installed on my old HDD. What should one do in that case, Tihiy?

I guess Miranda should be fixed to allow 32bit icons even on systems that wouldn't normally allow that, but there may be many other applications out there in the same situation.

Oh... congratulations, you did a great job! :thumbup

0

Share this post


Link to post
Share on other sites

Oh my God. This guy is making history.

I asked for this so many times over the years... I can't believe it's finally available!!!!!! :w00t:

THANK YOU TIHIY!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Edit:

Doesn't work here. NVIDIA video card w/ 32-bit support. :(

Edited by Dave.Net
0

Share this post


Link to post
Share on other sites

Dave.Net just showed me this thread.

Good work Tihiy. I think that if I had seen this 2 weeks ago, I wouldn't have ditched 2k for XP.

2k is a great OS; it is nice to finally see this needed improvement.

0

Share this post


Link to post
Share on other sites

Has this already been done years ago by Merijn and his Transicon program?

0

Share this post


Link to post
Share on other sites

I'm moving this to a more appropriate forum where more people interested in this will be exposed to it. Nice program, btw :).

0

Share this post


Link to post
Share on other sites
Doesn't work here. NVIDIA video card w/ 32-bit support.

Does it work for anyone? I think it is :blushing:

Well, in such cases:

1) Make sure you're running 32-bit video mode.

2) Rebuild icon cache. The easiest way to do this is to open Display->Effects->Check "Large Icons"->OK, Display->Effects->Uncheck "Large Icons"->OK.

3) NVIDIA drivers were crap in all Windows versions (especially now - poor Vista users). In Windows 98, driver bugs were cureable by rotating screen by some angle and rotating it back.

4) Un-register and register dll again.

5) If you still don't achieve anything, post screenshots and/or Dependancy Walker logs for program.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.