Sign in to follow this  
Followers 0
scottbrown5000

Unable to automate domain joining unattend.xml

2 posts in this topic

I feel as if I have tried everything, but I am still unable to automate the process of joining a workstation to my domain using autounattend.xml. Below is a sample of my xml file. If anyone is able to figure out what I am doing wrong I will be forever greatful!

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<OOBE>
<HideEULAPage>true</HideEULAPage>
<ProtectYourPC>2</ProtectYourPC>
<SkipUserOOBE>true</SkipUserOOBE>
<NetworkLocation>Work</NetworkLocation>
</OOBE>
<UserAccounts>
<LocalAccounts>
<LocalAccount wcm:action="add">
<Password>
<Value>password</Value>
<PlainText>true</PlainText>
</Password>
<Group>administrators;users</Group>
<Name>administrator</Name>
<DisplayName>administrator</DisplayName>
<Description>Local Admin</Description>
</LocalAccount>
</LocalAccounts>
<AdministratorPassword>
<Value>password</Value>
<PlainText>true</PlainText>
</AdministratorPassword>
<DomainAccounts>
<DomainAccountList wcm:action="add">
<DomainAccount wcm:action="add">
<Name>domain admins</Name>
<Group>administrators</Group>
</DomainAccount>
<Domain>domain.com</Domain>
<DomainAccount wcm:action="add">
<Group>administrators;users</Group>
<Name>domain admin account</Name>
</DomainAccount>
</DomainAccountList>
</DomainAccounts>
</UserAccounts>
<AutoLogon>
<Password>
<Value>PASSWORD</Value>
<PlainText>true</PlainText>
</Password>
<Domain></Domain>
<Enabled>true</Enabled>
<Username>administrator</Username>
<LogonCount>1</LogonCount>
</AutoLogon>
</component>
</settings>
<settings pass="specialize">
<component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<Identification>
<Credentials>
<Domain>DOMAIN.com</Domain>
<Username>domain admin account</Username>
<Password>PASSWORD</Password>
</Credentials>
<JoinDomain>DOMAIN.com</JoinDomain>
<MachineObjectOU>OU=computers,DC=domain,DC=com</MachineObjectOU>
<JoinWorkgroup></JoinWorkgroup>
<DebugJoin>false</DebugJoin>
<MachinePassword />
<UnsecureJoin>false</UnsecureJoin>
</Identification>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<ComputerName></ComputerName>
<ProductKey>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</ProductKey>
</component>
</settings>
<settings pass="generalize">
<component name="Microsoft-Windows-Security-Licensing-SLC" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SkipRearm>1</SkipRearm>
</component>
</settings>
<settings pass="windowsPE">
<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<DiskConfiguration>
<Disk wcm:action="add">
<CreatePartitions>
<CreatePartition wcm:action="add">
<Order>1</Order>
<Type>Primary</Type>
<Extend>true</Extend>
</CreatePartition>
</CreatePartitions>
<DiskID>0</DiskID>
<WillWipeDisk>true</WillWipeDisk>
<ModifyPartitions>
<ModifyPartition wcm:action="add">
<Active>true</Active>
<Format>NTFS</Format>
<Order>1</Order>
<PartitionID>1</PartitionID>
<Letter>C</Letter>
</ModifyPartition>
</ModifyPartitions>
</Disk>
<WillShowUI>OnError</WillShowUI>
</DiskConfiguration>
<EnableNetwork>true</EnableNetwork>
<UserData>
<ProductKey>
<WillShowUI>OnError</WillShowUI>
<Key>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</Key>
</ProductKey>
<AcceptEula>true</AcceptEula>
<Organization>Company name</Organization>
</UserData>
<ImageInstall>
<OSImage>
<InstallTo>
<DiskID>0</DiskID>
<PartitionID>1</PartitionID>
</InstallTo>
</OSImage>
</ImageInstall>
</component>
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SetupUILanguage>
<UILanguage>en-us</UILanguage>
</SetupUILanguage>
<InputLocale>en-us</InputLocale>
<SystemLocale>en-us</SystemLocale>
<UILanguage>en-us</UILanguage>
<UserLocale>en-us</UserLocale>
</component>
</settings>
<cpi:offlineImage cpi:source="wim://PC/image/install.wim#Windows Vista ENTERPRISE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>

0

Share this post


Link to post
Share on other sites

one little problem i struggled with was, that you have to use the "short" domain name instead of the full domain name in the answer file e.g: yourdomain instead of yourdomain.local

i managed to do an unattended domain join with this answer file...

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<servicing>
<package action="configure">
<assemblyIdentity name="Microsoft-Windows-Foundation-Package" version="6.0.6000.16386" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="" />
<selection name="TelnetClient" state="true" />
</package>
</servicing>
<settings pass="specialize">
<component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<Identification>
<Credentials>
<Domain>yourdomain</Domain>
<Username>domainuser</Username>
<Password>domainpass</Password>
</Credentials>
<JoinDomain>yourdomain</JoinDomain>
<DebugJoin>false</DebugJoin>
<UnsecureJoin>true</UnsecureJoin>
</Identification>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<OOBE>
<HideEULAPage>true</HideEULAPage>
<NetworkLocation>Work</NetworkLocation>
<ProtectYourPC>1</ProtectYourPC>
<SkipUserOOBE>true</SkipUserOOBE>
<SkipMachineOOBE>true</SkipMachineOOBE>
</OOBE>
<UserAccounts>
<AdministratorPassword>
<Value>xxxxxxxx</Value>
<PlainText>true</PlainText>
</AdministratorPassword>
</UserAccounts>
<BluetoothTaskbarIconEnabled>true</BluetoothTaskbarIconEnabled>
<ShowWindowsLive>false</ShowWindowsLive>
<AutoLogon>
<Password>
<Value>xxxxxxx</Value>
<PlainText>true</PlainText>
</Password>
<Domain></Domain>
<Enabled>true</Enabled>
<LogonCount>1</LogonCount>
<Username>Administrator</Username>
</AutoLogon>
<FirstLogonCommands>
<SynchronousCommand wcm:action="add">
<CommandLine>powercfg -change -standby-timeout-ac 0</CommandLine>
<Description>don't go to standby after 1 hour</Description>
<Order>1</Order>
</SynchronousCommand>
</FirstLogonCommands>
<RegisteredOrganization>yourorg</RegisteredOrganization>
</component>
</settings>
<settings pass="offlineServicing">
<component name="Microsoft-Windows-PnpCustomizationsNonWinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<DriverPaths>
<PathAndCredentials wcm:keyValue="c1574a1" wcm:action="add">
<Path>\\server\reminst\distribution\Out-of-Box Drivers</Path>
<Credentials>
<Domain>yourdomain</Domain>
<Password>yourpass</Password>
<Username>user</Username>
</Credentials>
</PathAndCredentials>
</DriverPaths>
</component>
</settings>
<cpi:offlineImage cpi:source="wim://server/microsoft/windows%20vista/wims/install.wim#Windows Vista ENTERPRISE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.