jetman

Super-Disc: Multi-Boot Project CD/DVD Using ISOLINUX

291 posts in this topic

To be honest your better off reading the README.menu file. It's a text file from the syslinux package and it explains it all quite well!

You can download it here (you want syslinux-3.36.zip) and you can read some of it here.

The main values you are interested in are MENU width and MENU margin and possibly MENU rows .

If you get stuck post back.

Edited by kof94
0

Share this post


Link to post
Share on other sites
To be honest your better off reading the README.menu file. It's a text file from the syslinux package and it explains it all quite well!

You can download it here (you want syslinux-3.36.zip) and you can read some of it here.

The main values you are interested in are MENU width and MENU margin and possibly MENU rows .

If you get stuck post back.

Sir Kof: I gave up after a while. Change one thing, then it moves in an unexpected direction or amount. Bah ! Let it be a little off-center ! Real men don't need centered menus anyway ! :P

@google44: Seriously, I think the positioning code is a bit buggy. I'd get a later version of SYSLINUX than the one my buddy Kof94 mentioned. I'm using 3.50-pre4. He's (ie. SYSLINUX' author) is a wee slow in releasing code. The Freshmeat page for the proj hasn't been updated in months, but the latest-greatest module is available at the Kernel.org link found on the SYSLINUX Downloads page....Jet

0

Share this post


Link to post
Share on other sites

I can set height and margin of the menu from the left or right but what about top margin ?

Edit: I just found out why is so difficult to center the menu. I don't think menu positioning code is buggy, the problem is with the MENU MARGIN setting which is working a bit ankward, at least.

MENU MARGIN and MENU WIDTH depends on each other for menu's to be in center of the screen. That is because when you set margin , the entire menu is not moved from left to right preserving menu width, only the left margin of the menu is moved to the right. So when you set MENU MARGIN 10, the right margin of the menu remains at the same position, only the left margin moves 10 points from left margin of the screen. So, of course, this affects width of the menu and because of that is very confusing.

Edited by google44
0

Share this post


Link to post
Share on other sites

This is driving me crazy I just couldn't boot anything. All my files and images are in ISOLINUX folder. I try it to boot like that:

LABEL sysresccd2

MENU LABEL ^2 Docmem

KERNEL /isolinux/memdisk

APPEND initrd=/isolinux/docmem.img

If i don't use graphical user interface, just text, is working fine but when I add vesamenu.c32 and chain.c32 to have a graphical interface it's just not working anymore, nothing happen when I want to run it.

What i'm doing wrong here because it's clear that all the files are in the right place ?

0

Share this post


Link to post
Share on other sites
I can set height and margin of the menu from the left or right but what about top margin ?

Edit: I just found out why is so difficult to center the menu. I don't think menu positioning code is buggy, the problem is with the MENU MARGIN setting which is working a bit ankward, at least.

MENU MARGIN and MENU WIDTH depends on each other for menu's to be in center of the screen. That is because when you set margin , the entire menu is not moved from left to right preserving menu width, only the left margin of the menu is moved to the right. So when you set MENU MARGIN 10, the right margin of the menu remains at the same position, only the left margin moves 10 points from left margin of the screen. So, of course, this affects width of the menu and because of that is very confusing.

Hate to tell you "I told you so" but... :whistle:

It's a bit of a pain really because each setting effects the other.

And as always the right honorable gentleman jetman continues to be a bastion for common sense. :D

Sir Kof: I gave up after a while. Change one thing, then it moves in an unexpected direction or amount. Bah ! Let it be a little off-center ! Real men don't need centered menus anyway !

Next topic:

This is driving me crazy I just couldn't boot anything. All my files and images are in ISOLINUX folder. I try it to boot like that:

LABEL sysresccd2

MENU LABEL ^2 Docmem

KERNEL /isolinux/memdisk

APPEND initrd=/isolinux/docmem.img

If i don't use graphical user interface, just text, is working fine but when I add vesamenu.c32 and chain.c32 to have a graphical interface it's just not working anymore, nothing happen when I want to run it.

What i'm doing wrong here because it's clear that all the files are in the right place ?

First up you don't need to add the isolinux folder location because you're already in it and you don't move from it. So if all your boot files are in the isolinux folder including all modules i.e. memdisk then your command should look like this:

KERNEL memdisk
APPEND initrd=docmem.img

Incidentally, Docmem plainly won't work via memdisk and I haven't found a viable solution that works properly yet. IMO memtest86+ does a good enough job, even if it is slow.

As for vesamenu not working, could you post your complete config files.

-kof94

Edited by kof94
0

Share this post


Link to post
Share on other sites

Below is the complete isolinux folder used as a pebuilder plugin. From the archive is missing setup98.img and splash.png image. With mkisofs4isolinux.cmd I make the iso image after i build it with pebuilder. Everything is working fine, isolinux graphical interface is booting, but when i select "Test" and press "enter" nothing happen

isolinux.rar

Here is what's inside pebuilder.iso after iso creation:

2003143554278067883_th.jpg

So I don't understand why setup98.img is not launching because everything seems to be ok.

0

Share this post


Link to post
Share on other sites

Sorry buddy I'm lost. When I boot my AIO DVD I boot straight to isolinux, I'm not quite sure what your trying to do here!

Are you trying to boot isolinux from a PE environment or am I missing something?

Could you also provide a link the full size image of your folder setup as well.

0

Share this post


Link to post
Share on other sites

There is nothing really special here, I just create an isolinux plugin for pebuilder. I boot also straight to isolinux there is absolutely no difference, except the two other folders which don't mater.

0

Share this post


Link to post
Share on other sites

Ok, fair enough.

I take it "Test" is a label for an app you want to boot, are you completely sure your commands are correct.

For example:

- You don't have two identical labels in your config file

- All your files conform to 8.3 standard

- You have the correct locations set e.g. /menus/main.cfg looks for a folder in the root or the disc called menus menus/main.cfg looks for the menus folder in the isolinux dir.

I know I might be asking silly questions here but simple things can really mess things up.

If your really not sure post your isolinux.cfg and any other config files your having troubles with and I'll take a look.

0

Share this post


Link to post
Share on other sites

This is isolinux.cfg file:

DEFAULT /vesamenu.c32
PROMPT 1
TIMEOUT 300


MENU BACKGROUND /splash.png
MENU TITLE Test


MENU COLOR title 1;36;44 #ff0000ff #00000000 std

MENU COLOR unsel 37;44 #ff0000ff #00000000 std

MENU COLOR sel 7;37;40 #c0ffffff #ff000000 std

MENU COLOR hotkey 1;37;44 #ffff0000 #00000000 std

MENU COLOR hotsel 1;7;37;40 #ff00ff00 #ff000000 all



LABEL test
MENU LABEL ^test
KERNEL memdisk
APPEND initrd=setup98.img

This is iso file:

2005737330182908524_rs.jpg

This is the isolinux folder:

2005667611676571974_rs.jpg

and this is the cmd file for building the iso:

@ECHO OFF
ECHO Starting @ (%TIME%) ....
SET _VNBR_=01
SET _ROOT_=C:\pebuilder3110a\plugin
SET CDTITLE="SUPERDISC-%_VNBR_%"
SET CDFILENAME="%_ROOT_%%CDTITLE%.ISO"
C:\pebuilder3110a\mkisofs.exe -N -V %CDTITLE% -b isolinux.bin -d -iso-level 4 -no-emul-boot -boot-load-size 4 -boot-info-table -o "c:\pebuilder.iso" "C:\pebuilder3110a\plugin\isolinux"

I don't understand why it's not working, everything is booting fine but when I try to run "test" item , nothing.

There are no other configuration files that could interfere so..

Edited by google44
0

Share this post


Link to post
Share on other sites

Visual communication saves the day, I think.

Create a folder at the root of your disc called isolinux, put everything in it then boot this config, then tell me if it works.

DEFAULT vesamenu.c32
PROMPT 0
TIMEOUT 300

MENU BACKGROUND splash.png
MENU TITLE Test

MENU COLOR title 1;36;44 #ff0000ff #00000000 std
MENU COLOR unsel 37;44 #ff0000ff #00000000 std
MENU COLOR sel 7;37;40 #c0ffffff #ff000000 std
MENU COLOR hotkey 1;37;44 #ffff0000 #00000000 std
MENU COLOR hotsel 1;7;37;40 #ff00ff00 #ff000000 all

LABEL test
MENU LABEL ^test
KERNEL memdisk
APPEND initrd=setup98.img

I know... I've only made two changes and I know... you can have everything at the root of the disc but please just indulge me.

EDIT: Sorry I made a few more changes!

EDIT: And again. Avoid using tab!

Edited by kof94
0

Share this post


Link to post
Share on other sites

it's the same thing but if I change it to something like that it works (instead of default vesamenu.c32 i change it to default test):

DEFAULT test
PROMPT 0
TIMEOUT 300

MENU BACKGROUND splash.png
MENU TITLE Test

MENU COLOR title 1;36;44 #ff0000ff #00000000 std
MENU COLOR unsel 37;44 #ff0000ff #00000000 std
MENU COLOR sel 7;37;40 #c0ffffff #ff000000 std
MENU COLOR hotkey 1;37;44 #ffff0000 #00000000 std
MENU COLOR hotsel 1;7;37;40 #ff00ff00 #ff000000 all

LABEL test
MENU LABEL ^test
KERNEL memdisk
APPEND initrd=setup98.img

setup98.img is booted directly so the menu is ok I guess. I think I am missing something here.

Edited by google44
0

Share this post


Link to post
Share on other sites

I just built a test build using just isolinux.cfg.

isolinux.cfg:

PROMPT 0

DEFAULT vesamenu.c32

MENU MARGIN 0
MENU ROWS 19
MENU TABMSGROW 24
MENU CMDLINEROW 24
MENU TIMEOUTROW 24
MENU BACKGROUND backgrd.png

MENU COLOR border 37;44 #00000000 #00000000 none
MENU COLOR title 37;44 #ffffffff #00000000 std
MENU COLOR unsel 37;44 #80ffffff #00000000 std
MENU COLOR sel 34;47 #ffffffff #10ffffff std
MENU COLOR scrollbar 37;44 #80ffffff #00000000 std
MENU COLOR tabmsg 30;40 #00000000 #00000000 none
MENU COLOR cmdline 37;40 #80ffffff #00000000 std
MENU COLOR cmdmark 37;40 #f0d60000 #00000000 std
MENU COLOR timeout_msg 37;40 #ffffffff #00000000 std
MENU COLOR timeout 31;40 #f0d60000 #00000000 std

MENU TITLE The First .img I saw!

LABEL seatools
MENU LABEL Seatools 1.09 (Seagate)
KERNEL memdisk
APPEND initrd=seatools.igz

Contents of isolinux folder:

isolinux.cfg
memdisk
vesamenu.c32
seatools.igz
backgrd.png
chain.c32
isolinux.bin

All works A-OK.

I'm not quite sure where your going wrong to be honest.

0

Share this post


Link to post
Share on other sites

I don't know what's the problem, it just don't work in graphical mode. It works ok only in text mode.

0

Share this post


Link to post
Share on other sites
There is nothing really special here, I just create an isolinux plugin for pebuilder. I boot also straight to isolinux there is absolutely no difference, except the two other folders which don't mater.

NO ! Incorrect. ISOLINUX is just a loader, a facilitator to get your CD-based systems started. It's just like GURB, BCDW, or CDSHELL. I've been using BartPE for years and no way would I ever do an ISOLINUX plugin.

ISOLINUX+GRUB+CDSHELL+whatever start bef any CD-based app/system and exist solely for that purpose. Do as you will with your computer, but you've missed the point of the exercise....Jet

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.