chon_

HOWTO: Windows Vista x86 and x64 in the same DVD

77 posts in this topic

No one never answered here. Is it possible to have x86 anx64 working with an autounattended.xml file?

0

Share this post


Link to post
Share on other sites

Should be yea.

I havent tried it myself.

0

Share this post


Link to post
Share on other sites

it doesn't work... the xml file needs to be specified with the OS architecture, so it works for one and not for the other one...

Is there a way to combine them?

0

Share this post


Link to post
Share on other sites

I have Win 7 Enterprise, and it doesn't work for me.

All I get is this and that is all>

post-8982-086650900 1284652631_thumb.png

this is how my commands look like:



imagex /export D:\VistaAIO\x86\install.wim 1 .\install.wim "Windows 7 Enterprise x86 BIE"

imagex /export D:\VistaAIO\x64\install.wim 1 .\install.wim "Windows 7 Enterprise x64 BIE"

oscdimg -n -bD:\VistaAIO\distribucion\boot\etfsboot.com D:\VistaAIO\distribucion d:\Win7-Ent_x32_x64.iso -m

0

Share this post


Link to post
Share on other sites

"Windows 7 Enterprise x86 BIE"

"Windows 7 Enterprise x64 BIE"

looks like warez, which is not allowed here to talk about :whistle:

0

Share this post


Link to post
Share on other sites

it is warez, but I got a license anyway-MSDNAA :)

I prefer the non official Windows versions because of the darn activation software. Which always gets in the way esspecially when switching GPU's, which I do quite often ;)

0

Share this post


Link to post
Share on other sites

MagicAndre

You gave me the idea to try with the official MSDNAA images. And there it works great.

All I had to do was delete the EI.CFG and change the numbers to 4 for x32 and 5 for x64 Win 7 Ultimate

btw. Anybody got any idea why it doesn't work with the BIE release?

0

Share this post


Link to post
Share on other sites

delete the last comments about the warez version ;) Or do you want a ban?

Use the MSDNAA version and be happy.

0

Share this post


Link to post
Share on other sites

delete the last comments about the warez version ;) Or do you want a ban?

Use the MSDNAA version and be happy.

Will delete the comments about WAREZ version, if you want?

I just didn't see the point of lying about it especially since I own the genuine Windows.

btw. To the guide on the first page it should be added how to do it for Windows 7. I can happily make the proper changes, and then a mod can edit the OP's post to also add the section about Win 7 and then also change the title of this thread.

Edited by BigDaddy
0

Share this post


Link to post
Share on other sites

Same thing for creating a 7 AIO..

First alt is to execute commans below

Imagex /export "old install.wim" "index" "new install.wim" "editionname 32Bit" (index 1-5)

Imagex /export "old install.wim" "index" "new install.wim" "editionname 64Bit" (index 1-4)

Do the above for all 9 (or 8 if not starter) and then replace the old install.wim with the new one

Or you can do this

Imagex /export "64bit dvd install.wim" "index" "32bit dvd install.wim" "editionname 64Bit" (index 1-4)

then use oscdimg command to create new iso and then burn, size for english will be around 3.6 GB without enterprise.

0

Share this post


Link to post
Share on other sites

If you need to integrate several versions on to a single disk, you may need to split the WIM image, otherwise it won't be read properly.

Here's another post that can help you split the images. http://www.msfn.org/...wim-4gb-for-w7/

The format used to create the ISO doesn't support >~4gb WIMs. So you can use imagex /split to split it and then use oscdimg to make the ISO.

Create your modified WIM images.

Merge them into a single install.wim.

Then split the wim using imagex.

Create the ISO using oscdimg or vLite.

I merged all versions of x86 and x64 into install.wim and then did the following:

imagex /split Install.wim Install.SWM 4096 /check

oscdimg -b"D:\Images\ISOs\Windows Vista\Distribution\boot\etfsboot.com" -u2 -h -m -lVistaOct10 "D:\Images\ISOs\Windows Vista\Distribution" ".\Windows Vista AIO.iso"

May be redundant using UDF, not sure.

Edited by EneergE
0

Share this post


Link to post
Share on other sites

Well 2 editions will fit on a 4.5 GB DVD but not an full AIO.

0

Share this post


Link to post
Share on other sites

Hi.

I too tried to join Vista SP2 x86 and Vista SP2 x64.

Each one is installing fine and fast in VirtualBox. But whey they are "together" the setup is very slow, beginning with the window that shows the editions. Specifically each window appears after many minutes + pressing the buttons to do something inside the window is also carried out very slow (for example when you want to format the partition).

The setup isn't frozen, you can move the mouse easily.

In the host OS Task Manager shows that one of two processors is constantly at 100% (VirtualBox). Soon as the next window appears or the command is carried out the processor usage drops to 0.

Can you please help me solve this problem?

Thank you in advance.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.