• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
dexter.inside

The Art of OEM - nLite & OEM Preinstallation

Your opinion goes here   140 members have voted

  1. 2. Would you like for Windows Designer Studio to perform most of the operations described in this guide?

    • Yes, and I want more features too!
      68
    • Yes
      13
    • No, I'd rather stick with the plain old Windows Setup routine.
      5
    • No, it's just a waste of time; nLite/vLite will always be enough for my needs.
      7
  2. 3. Now that this guide is complete, are you happy with its contents?

    • Yes, it's a great idea!
      62
    • Somewhat, I used some of the things described here.
      20
    • Probably, but it is too complex for me to handle.
      7
    • No
      4
  3. 4. Which of these should benefit you the most and you'd like to see first in Windows Designer Studio? (more details soon)

    • Windows Setup SDK (Panther Engine) - WIM capture, Setup customization and ISO making, like in Parts 3 and 4
      45
    • VKEY Explorer - an advanced tool to design the registry of the OS you are designing
      5
    • Package Designer - a set of diff and compression tools to allow you to author/create/add/remove windows components and preinstalled apps
      18
    • VM Workbench - an extension for the free VMware Player product to test the results of your work before finalizing
      10

Please sign in or register to vote in this poll.

141 posts in this topic

Hi guys.

Dexter.inside

I tryed the guide and solved my previous problems whit sysprep section, the err0r was some MassStorages drivers

now i pased of this part.

After its i mount and imaging the partition, copy to sources folder of longhorn,but whe i try

to install all its fine, before begin the copy files then the setup

sendme this error...

Setup cant copy files

....

tanks in advance

i wait fr your helpdexter plz.

0

Share this post


Link to post
Share on other sites

Are you using sysprep -bmsd to populate sysprep.inf ?

Try this to make sure it's not something else causing it -

in HKLM\SYSTEM\Setup add or modify:

Cmdline:REG_SZ:setup -newsetup -mini

MiniSetupInProgress:REG_DWORD:0x1

SetupType:REG_DWORD:0x1

SystemSetupInProgress:REG_DWORD:0x1

and

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\SetupExecute:REG_MULTI_SZ:setupcl.exe

(according to http://support.microsoft.com/kb/321070)

This should run mini-setup without driver detection. If this fails, you should post the last stuff that failed in the setup log. If it doesn't, you are not building mass storage driver list properly.

If you have extra steps to perform (related to drivers) or you need to bypass completely the windows mini-setup driver detection (like driverpacks), append it in the REG_MULTI_SZ after setupcl.exe

Hope it helps. It did for me.

Edited by dexter.inside
0

Share this post


Link to post
Share on other sites

Tanks dexter. :thumbup

Sure i use Sysprep -bmsd, and for the moment i skip the aditional MassStorage Drivers and its working.

Sysprep has pased, now i mount the drive and imagining it, patch with tiny hexer.

Add Eula, etc, and work fine.

But, when its hour to copy files after select partition to install, it giveme the next error.

Error trying copy files, and after i click ok, its close

I think that its for version of imagex that i use, so i download ximagex for longhorn,

whit this versio i can see /info and manipule install.wim of longhorn,but no, its not working the error is the same

Tanks for advance, you are great man,I very interesting on your guide, but i see no much people searching or

trying it. :blushing:

0

Share this post


Link to post
Share on other sites

That means either your image is corrupted at editing or setup is incompatible with that WIM API.

Have you tried booting from a live cd and applying your image manually with ximage onto the target partition to see if it works?

0

Share this post


Link to post
Share on other sites

Hi dexter.

I am very happy for you help.

:thumbup

I try its that you sayd, and i will post when i do it.

tanks.

ooo

And dexter, do you have boths images or iso`s that you use in this guide,

and if its not problem, its are downloable?

If its yes, where i download i search for months but i dont found, i found it in the warez web`s

but someones links are dead, they are in rapidshare, megaupload, Torrents, and others but all theys

are deads, not working.

Do you giveme this iso`s?

i hope that its not offend you. :unsure:

oks tanks.

I hope have much more conversations whit you, maybe in msn.

0

Share this post


Link to post
Share on other sites

I list segui trying i finally it, copies the files, for some reason though it patches the install.wim with the mirkes hexer, and the/info shpwme the correct Image Index, it was not loading it, because the image inndex is not recognizes by the setup,

when i try to apply the install.wim directly whit

ximage /apply path\install.wim z: 3

it sayd that the image not exist in the install.wim

But now that I have added 2 images mas in the same install.wim, it copies the files and finishes the installation, and makes me the first boot, and after the Bootscreen, now it throws a BSOD,.

i will trying,

and post later...

0

Share this post


Link to post
Share on other sites

well i try all.

and already is finish it, in the virtual machine i had a BSOD an reboot inmediatly, but, in a normal machine all is work.

and i finish the instalñation proces, Driver detection and i had my desktop of the same form when i capture it,

tanks for the help,

Now i whis add more More MassStorage drivers and other driver to my instalation, so i tri it and post.

See you later dexter.inside

0

Share this post


Link to post
Share on other sites
well i try all.

and already is finish it, in the virtual machine i had a BSOD an reboot inmediatly, but, in a normal machine all is work.

Quite normal, if you have a SCSI/SAS drive in the VM and no mass storage driver for it. XP usually goes with BusLogic and Server 2003 with LSI

As for the disks, they are not mine, I've used the deployment server at work for the tutorial. My employer wouldn't be very happy if I were to share their MSDN subscription :whistle:

0

Share this post


Link to post
Share on other sites

well its fine...

im testing the burned cd rom in diferents pcs, and its work great,

only i had problems in to virtual machine,but its fine for the moment,

Tanks for all your help and time to deply tis guide,

so i hope that you will teach us, in this proyect or others i very happy if exist more proyects that try,

well tanks. and see you later.

And it isnt a bye, is only see you later,i will try a post in msfn.and hope that you =.

:thumbup

0

Share this post


Link to post
Share on other sites

I've been getting quite close on a new approach of servicing drivers into images, by bypassing sysprep altogether and running the mini-setup manually. Unfortunately it's both tricky to perform manually (very complex procedure) and difficult to implement properly as code in my app. Hope to get a workable engineering sample soon, as I've overcome the "legal" aspects

I'll keep you posted.

0

Share this post


Link to post
Share on other sites
well isaid " i try it" and i do...

when i use sysprep its erros appear.

error to reseal.

error to update registry

what id o wrong?

sorry for my bad english

Btw, I have a better idea... :sneaky:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\Setup]
"SetupType"=dword:00000001
"SystemSetupInProgress"=dword:00000001
"CmdLine"=hex(7):73,00,65,00,74,00,75,00,70,00,2e,00,65,00,78,00,65,00,20,00,\
2d,00,6e,00,65,00,77,00,73,00,65,00,74,00,75,00,70,00,20,00,2d,00,6d,00,69,\
00,6e,00,69,00,00,00,00,00
"MiniSetupDoPnP"=dword:00000001
"MiniSetupInProgress"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager]
"SetupExecute"=hex(7):73,00,65,00,74,00,75,00,70,00,63,00,6c,00,2e,00,65,00,78,\
00,65,00,00,00,00,00

Skip sysprep altogether and apply this reg. It will get you back to mini-setup.

The nasty part was to discover "MiniSetupDoPnP"=dword:00000001 , which AFAIK is undocumented.

0

Share this post


Link to post
Share on other sites

oks tanks

i will try it in few days...

and in Vmware and real pc`s

i`ll try to add sata massStorage drivers in new try.

i dont stop of try.

0

Share this post


Link to post
Share on other sites

This is the first time i have ever posted here after lurking for a couple years as a guest :)

I really enjoyed this guide and the rest of the msfn site, has given me a lot of great ideas on customizing my xp and 2003!.

I have been trying to sort out where the failure is for low memory systems on windows home server. Apparently, the WPE 2.0 environment WILL function without errors on 256 mb of ram, if you access a command prompt and create a pagefile on the hard drive, via wpeutil CreatePageFile <pagefile_name>, i had to edit winpeshl.ini and remove qs.exe and add cmd.exe in this file.

This remaining stuff i did was in Normal boot mode. did the rest in a full windows windows sbs install.

I unhid the whs optional components INF after i installed the whs component exe's and right click installed the whsoc.inf file. Then accessed cmd.exe again, then entered install.cmd from \files\install on the whs media then rebooted.

It appears qs.exe then exhibits strange behavior and bypasses the RAM check on the next reboot, the strange behavior is exhibited by using the bogus registry keys install.cmd entered, install.cmd made the assumption the media is on the drive you are booting from. The weird thing as well, that the media you called qs.exe from is now drive X: on reboot and your not even on PE!! and the install is hosed when i didnt do the previous steps before. i could NOT even logon.

I have a suspicion that whs is convertable if it can be figured out how to do this procedure without locking yourself out. or having strange drive assignments.

i would like to have otheres test this out on a non important installation.

It seems you need a good portion of the dvd directory structure and files in the root of the drive your attempting this on.

1). Unhide the windows components hidden in sysoc.inf, from your hard drive

2). install the inf from \windows\inf\whsoc.inf. from your hard drive.

3). Installed the whs components in \whs on your install media.

4). enter install.cmd from \files\install from your install media while in a normal windows session.

5). either reboot and allow the system to run qs.exe on next logon.

0

Share this post


Link to post
Share on other sites

Ok, I have a WIM of my sysprepped XP, and I want to deploy it via CD/DVD. I've read through this guide a few times, and I'm confused by the stuff about using the Panther engine. I just want to deploy my WIM the same way Vista does, IE, pick language, partition, install.

Can anyone tell me what I should do?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.