Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Vista unattended Guide

- - - - -

  • Please log in to reply
288 replies to this topic

#1
FireGeier

FireGeier

    Advanced Member

  • Member
  • PipPipPip
  • 405 posts
  • Joined 24-October 05
Hello @ all!

Following the idea of sharing, here is my unattended Vista Guide. It's a mixture between docs of WAIK and own experiences praticing with Vista unattended setups.

I've started writing German Vista guidlines a while ago and got a lot request meanwhile to translate parts of it to English. The guide is still under progress but a lot of stuff is available now:

THE FOLLOWING LINKS NO LONGER WORK

[url="http://firegeier.unattended-sponsor.de/en/sitemap.html"][b]NEW: Sitemap / TOC[/b][/url]
1. [url="http://firegeier.unattended-sponsor.de/en/introduction.html"]Introduction[/url]
2. [url="http://firegeier.unattended-sponsor.de/en/install_tools.html"]Installing Tools[/url]
3. [url="http://firegeier.unattended-sponsor.de/en/folder_structur.html"]Prepare Lab System[/url]
4. [url="http://firegeier.unattended-sponsor.de/en/vu_batch_modules.html"]VU Batch Modules[/url]

5. [url="http://firegeier.unattended-sponsor.de/en/answer_file_1.html"]Building a Basic Answer File using WSIM[/url]
6. [url="http://firegeier.unattended-sponsor.de/en/partitioning.html"]Partitioning[/url] and [url="http://firegeier.unattended-sponsor.de/en/part_snipps.html"]Partitioning XML snippets[/url]
7. [url="http://firegeier.unattended-sponsor.de/en/create_iso.html"]Creating Vista ISO[/url]
8. [url="http://firegeier.unattended-sponsor.de/en/inject_drivers_into_image.html"]Injecting drivers into install.wim[/url]
9. [url="http://firegeier.unattended-sponsor.de/en/drivers_from_stick_or_dvd.html"]Installing drivers directly from media[/url]
10. [url="http://firegeier.unattended-sponsor.de/en/updates.html"]Integrating Updates into install.wim[/url]
11. [url="http://firegeier.unattended-sponsor.de/en/applications.html"]Installing Applications from media[/url]
12. [url="http://firegeier.unattended-sponsor.de/en/regtweaks.html"]Importing Regtweaks[/url]
13. [url="http://firegeier.unattended-sponsor.de/en/copy_profile_to_default_user.html"]Copying over user profile to Default User [/url](makes sense for User Regtweaks)


I'm not a to well html programer, so I know that there are still some issues with layout on different browsers, but it's working mainly.

If you've any problems with the guide please post in this thread!

Please DO NOT ask for settings, which are not described in the guide in this thread.

This thread supposed to be for error reporting and feedback only!


NOTE:
1. I've tested the guide on 32 bit OS only, updates for 64 bit will come any time later.
2. I've tested all the described procedures carefully. However it could happen, that something will not run on your system like described.
3. This is NOT a one click and go guide! It's for people how like to know, how to setup without any third party tools.
4. Parts of the guides, which are not available in English yet are not necessary to follow the rest of the instructions!
Everything is translated now!


Regards,
Martin

Edited by Tripredacus, 23 September 2011 - 08:40 AM.
put code tags around links



How to remove advertisement from MSFN

#2
toastycheese678

toastycheese678

    Junior

  • Member
  • Pip
  • 64 posts
  • Joined 02-December 04
Excellent Guide. Im going to study it and walk through it. Ill let you know of any other details I think you should add. But by the looks of it nice job. Send another post when it is updated.

One other thing...PDF possibly?

Edited by toastycheese678, 29 March 2007 - 06:41 PM.

-Toastycheese678-

#3
MAVERICKS CHOICE

MAVERICKS CHOICE

    The Guy from Aus

  • Member
  • PipPipPipPipPipPipPip
  • 1,782 posts
  • Joined 14-November 03
  • OS:Windows 7 x64
  • Country: Country Flag
@Martin

Thats a wonderful guide dude, surely appreciated to many here.
Mind you have guided me most of it here one thread or another... :thumbup :thumbup

EDIT: Looking through your guides I think thats more than good enough to become the new MSFN Vista Unattended guide????Whaddya reckon guys??

Edited by MAVERICKS CHOICE, 30 March 2007 - 01:59 AM.


#4
FireGeier

FireGeier

    Advanced Member

  • Member
  • PipPipPip
  • 405 posts
  • Joined 24-October 05
@ toastycheese:

PDF would be possible generaly but I don't plan to do it before everything is finished and I've got confirmations, that it's working well. It's a freetime project, so at least everything costs time.

Timetable for the moment:
1. Translating the rest of docs I've finished in German allready ---> next tow weeks
2. Adding further stuff, if highly requested ---> depends on you, later on me! :sneaky:
3. Let it run for a test while.

Beside I've to work to feed myself and doing most of supporting part in German Vista forum part! :hello: :thumbup

But don't missunderstand, suggestions of improvement are welcome!

@MC:
I've had the idea to let this guide run a while for testing on my subdomain on windows-unattend.de. If everything seems to be fine and finished, it could be copied over to MSFN server, if requested... or use the guide or parts of it as draft... or whatever...

Thanks & regards,
Martin

Edited by FireGeier, 31 March 2007 - 04:44 AM.


#5
Yagermeister

Yagermeister

    Newbie

  • Member
  • 16 posts
  • Joined 28-January 04
Thanks for the nice guide but i somehow dont have any pictures. Are they broken or am i missing something here?

[EDIT]
Nevermind it seems firefox blocked them :P

Edited by Yagermeister, 30 March 2007 - 05:05 AM.


#6
maxXPsoft

maxXPsoft

    MSFN Master

  • Developer
  • 2,889 posts
  • Joined 14-November 03
  • OS:Windows 7 x64
  • Country: Country Flag
Handy for the Beginners as well for Advanced FireGeier :thumbup
I only had 1 problem with injecting driver's and that was any place I try to add /l:
Remove logging and it injects them 123, real nice.
This is error I get and maybe you can add to that part if you get logging error then remove and check the Windows\Inf instead.

Attached Files


Download ++> Windows 7 + 8 Unattended DVD + App Installer + Services Disabler + Load All Button + XML Creator
Jump2Reg - Registry: - Oct 4, 2013 - Version 3.0.4 - 98, ME, NT, 2K, XP, VISTA, Seven, Windows 8+ and 32 or 64 bit

XP Unattended CD/DVD creator - Version 4.1.7
Sample xml + Setupcomplete + Add Right click .wim Windows 7 or Windows 8/8.1

#7
Yagermeister

Yagermeister

    Newbie

  • Member
  • 16 posts
  • Joined 28-January 04
I seem to have a error when i try to install vista on vmware/virtualpc/virtualbox. If i use the clean dvd without the auto file i can configure my hdd just fine, but when i use the auto file (on floppy or dvd) then i get the error that i cant use the hdd. I believe the error code was 80300003. I tried searching for it but cant find anything.

I also doublechecked the auto file to see if there where some wrong links but everything was just as you displayed on your website. Do you perhaps know how to fix this?

#8
FireGeier

FireGeier

    Advanced Member

  • Member
  • PipPipPip
  • 405 posts
  • Joined 24-October 05

Handy for the Beginners as well for Advanced FireGeier :thumbup
I only had 1 problem with injecting driver's and that was any place I try to add /l:
Remove logging and it injects them 123, real nice.
This is error I get and maybe you can add to that part if you get logging error then remove and check the Windows\Inf instead.


Hello maxXPsoft!

Have you tried to do the injection on a XP system or on a Vista system? I haven't had any problems with logging but thanks for the feedback. I will add a note later!

Thanks,
Martin

#9
FireGeier

FireGeier

    Advanced Member

  • Member
  • PipPipPip
  • 405 posts
  • Joined 24-October 05

I seem to have a error when i try to install vista on vmware/virtualpc/virtualbox. If i use the clean dvd without the auto file i can configure my hdd just fine, but when i use the auto file (on floppy or dvd) then i get the error that i cant use the hdd. I believe the error code was 80300003. I tried searching for it but cant find anything.

I also doublechecked the auto file to see if there where some wrong links but everything was just as you displayed on your website. Do you perhaps know how to fix this?


Hello Yagermeister!


Well, if you use the basic Autounattend.xml you should be asked for the disk configuration. Do you get the disk configuration dialog before getting this error? And how long does it take, till you get the error?

Regards,
Martin

Edited by FireGeier, 31 March 2007 - 04:53 AM.


#10
Yagermeister

Yagermeister

    Newbie

  • Member
  • 16 posts
  • Joined 28-January 04

I seem to have a error when i try to install vista on vmware/virtualpc/virtualbox. If i use the clean dvd without the auto file i can configure my hdd just fine, but when i use the auto file (on floppy or dvd) then i get the error that i cant use the hdd. I believe the error code was 80300003. I tried searching for it but cant find anything.

I also doublechecked the auto file to see if there where some wrong links but everything was just as you displayed on your website. Do you perhaps know how to fix this?


Hello Yagermeister!


Well, if you use the basic Autounattend.xml you should be asked for the disk configuration. Do you get the disk configuration dialog before getting this error? And how long does it take, till you get the error?

Regards,
Martin


With some fiddling i found out where the error is but and how to solve it using a copy of some other parts from a other auto file but then its not complete unattended anymore. I get the error while being at the disk configuration btw.

I found out that the following code gives the trouble:

When i replaced it with the following it did work but i got a question which version Vista i wanted to install:

Do you perhaps have a idea how i can get around the box asking which to install?

#11
FireGeier

FireGeier

    Advanced Member

  • Member
  • PipPipPip
  • 405 posts
  • Joined 24-October 05

When i replaced it with the following it did work but i got a question which version Vista i wanted to install:


Do you perhaps have a idea how i can get around the box asking which to install?


Hello Yagermeister!

I can explain why you getting this box! This part here is wrong:

<InstallFrom>
	<MetaData wcm:action="add">
		<Value>Windows Vista ULTIMATE</Value>
		<Key>1</Key>
	</MetaData>
</InstallFrom>

This will cause an error and cause you use this setting here:

<WillShowUI>OnError</WillShowUI>

The whole User Interface of image selection is shown.


It has to be like described in guide:

<InstallFrom>
	<MetaData wcm:action="add">
		<Value>Windows Vista ULTIMATE</Value>
		<Key>IMAGE/NAME/</Key>
	</MetaData>
</InstallFrom>

Than you will not be asked, which Version you like to install!

I get the error while being at the disk configuration btw.


So what are you doing during disk configuration? Do you create new partitions? Do you format only?

Regards,
Martin

#12
FireGeier

FireGeier

    Advanced Member

  • Member
  • PipPipPip
  • 405 posts
  • Joined 24-October 05
@ maxX:

When you getting the error do you have the following Key present in your Registry?

HKLM\Software\Microsoft\Windows\CurrentVersion\Device Installer\DebugPkgMgr

Value=1

Regards,
Martin

#13
Yagermeister

Yagermeister

    Newbie

  • Member
  • 16 posts
  • Joined 28-January 04

When i replaced it with the following it did work but i got a question which version Vista i wanted to install:
Removed


Hello Yagermeister!

I can explain why you getting this box! This part here is wrong:

<InstallFrom>
	<MetaData wcm:action="add">
		<Value>Windows Vista ULTIMATE</Value>
		<Key>1</Key>
	</MetaData>
</InstallFrom>

This will cause an error and cause you use this setting here:

<WillShowUI>OnError</WillShowUI>

The whole User Interface of image selection is shown.


It has to be like described in guide:

<InstallFrom>
	<MetaData wcm:action="add">
		<Value>Windows Vista ULTIMATE</Value>
		<Key>IMAGE/NAME/</Key>
	</MetaData>
</InstallFrom>

Than you will not be asked, which Version you like to install!

I get the error while being at the disk configuration btw.


So what are you doing during disk configuration? Do you create new partitions? Do you format only?

Regards,
Martin


I think i have a idea why it fails. Maybe its because the KEY part is in front of the name itself. That is the only reason why i can imagine that it goes wrong there.

The part where it goes wrong is the disk configuration itself no matter what i do or want todo. See the attached picture for the precise error.

[EDIT]
After changing the KEY part to what you said i still get the listbox asking which version to install :S

[EDIT2]
Found the error: you accidently added a / after /IMAGE/NAME/ :P and as far as i can tell from the created ones it isn't supposed to be there. Testing again now.

[EDIT3]
And yes the error was indeed the extra /. I also found out why i had the error and the solution is actually quite simple considering the WAIK messed up there.

The KEY part should be added after the VALUE and not before as it was made with my WAIK. Then the disk configuration seems to work just fine.

Attached Files


Edited by Yagermeister, 31 March 2007 - 07:59 AM.


#14
FireGeier

FireGeier

    Advanced Member

  • Member
  • PipPipPip
  • 405 posts
  • Joined 24-October 05
Hello Yagermeister,

You're right, the "\" at the end was one to many, sorry for that. But that's explained right inside guide.

However the problem is very strange. Sure it makes sense to have the key setting in front of the value. But I had unattended files where such a thing hapened, too, but setup was just running fine. But at least I wonder about nothing dealing with computers and software. :D

However it's strange!

Thanks for your feedback!

Martin

#15
Yagermeister

Yagermeister

    Newbie

  • Member
  • 16 posts
  • Joined 28-January 04
A extra letter can always happen like you said on your website aswell. I do find the solution strange aswell as you would say that it would just skip it or read back whenever its needed. It would be handy if you put it as a extra note on the website just in case someone is getting the same error.

#16
FireGeier

FireGeier

    Advanced Member

  • Member
  • PipPipPip
  • 405 posts
  • Joined 24-October 05

A extra letter can always happen like you said on your website aswell.


You're right unfortunatly. But these are the kind of errors, which can drive you nuts.

I give my best to avoid. But if you read over your "own stuff", you're not able to detect some errors sometimes. :(


It would be handy if you put it as a extra note on the website just in case someone is getting the same error.


I will do so later!

Martin

#17
airmr

airmr

    Junior

  • Member
  • Pip
  • 81 posts
  • Joined 21-October 03
Hi,

i followed your guidelines and started the install. It still asks for the Serial number as if it couldnt find the Unattended.xml file.
I tried it on cd and on usb stick. I checked the tutorial and my dvd twice and it seems allright

any ideas why ?
Honk if your Jesus!!!

Most times its just the Netwok Cable.
The pitty is, that you reinstalled and configured for hours before you tested it.

#18
Yagermeister

Yagermeister

    Newbie

  • Member
  • 16 posts
  • Joined 28-January 04

Hi,

i followed your guidelines and started the install. It still asks for the Serial number as if it couldnt find the Unattended.xml file.
I tried it on cd and on usb stick. I checked the tutorial and my dvd twice and it seems allright

any ideas why ?


Here is how i have it and this works just fine:

<UserData>                <ProductKey>                    <Key>Enter key here with the - in between</Key>                    <WillShowUI>OnError</WillShowUI>                </ProductKey>                <AcceptEula>true</AcceptEula>                <FullName>Gebruiker</FullName>                <Organization>Eigen</Organization>            </UserData>


#19
FireGeier

FireGeier

    Advanced Member

  • Member
  • PipPipPip
  • 405 posts
  • Joined 24-October 05

Hi,

i followed your guidelines and started the install. It still asks for the Serial number as if it couldnt find the Unattended.xml file.
I tried it on cd and on usb stick. I checked the tutorial and my dvd twice and it seems allright

any ideas why ?


If you would have followed the guide the name of your answer file should be Autounattend.xml. No other name will work automatically.

If you should have named it Autounattend.xml already, have you tried to put it in sources folder, too?

How is your target system is looking like? VM? Real computer?

Regards,
Martin

#20
airmr

airmr

    Junior

  • Member
  • Pip
  • 81 posts
  • Joined 21-October 03
Hi,

i have probably named it autounattend.xml just wrote it wrong in the post :P
but ill check.

I havent tried the source folder version yet, will do that tonight. Ill let you know asap if that works.

Im testing with a burned dvd and a real pc :) <-- old fashioned but more fualt resistant :)

@Yager ill try your config file and see if i have something wrong in mine.

Thnx for the quick answers.

Edited by airmr, 02 April 2007 - 06:52 AM.

Honk if your Jesus!!!

Most times its just the Netwok Cable.
The pitty is, that you reinstalled and configured for hours before you tested it.

#21
maxXPsoft

maxXPsoft

    MSFN Master

  • Developer
  • 2,889 posts
  • Joined 14-November 03
  • OS:Windows 7 x64
  • Country: Country Flag
FireGeier
First I was doing it from XP and the reg key don't exist. I didn't have WAIK on because I'm only using the Servicing folder.
I'll boot into Vista and get the whole keys and maybe point it at my Servicing folder and give it a try.

EDIT: Nope that key don't exist in Vista for me after I installed AIK

Edited by maxXPsoft, 02 April 2007 - 07:10 AM.

Download ++> Windows 7 + 8 Unattended DVD + App Installer + Services Disabler + Load All Button + XML Creator
Jump2Reg - Registry: - Oct 4, 2013 - Version 3.0.4 - 98, ME, NT, 2K, XP, VISTA, Seven, Windows 8+ and 32 or 64 bit

XP Unattended CD/DVD creator - Version 4.1.7
Sample xml + Setupcomplete + Add Right click .wim Windows 7 or Windows 8/8.1

#22
FireGeier

FireGeier

    Advanced Member

  • Member
  • PipPipPip
  • 405 posts
  • Joined 24-October 05
Hello maxX!

Please add this key to the registry and try it again.

The type is REG_DWORD.

Regards,
Martin

EDIT:
Have added a description of the whole Regedit procedure to the guide (Injecting drivers...)

Edited by FireGeier, 02 April 2007 - 01:21 PM.


#23
maxXPsoft

maxXPsoft

    MSFN Master

  • Developer
  • 2,889 posts
  • Joined 14-November 03
  • OS:Windows 7 x64
  • Country: Country Flag
After you mentioned the reg key I remembered I had crossed that road before so went lookin in the waik.chm and found it. Its logging now even for my Hotfixes so I can look at what MS does there also.
Download ++> Windows 7 + 8 Unattended DVD + App Installer + Services Disabler + Load All Button + XML Creator
Jump2Reg - Registry: - Oct 4, 2013 - Version 3.0.4 - 98, ME, NT, 2K, XP, VISTA, Seven, Windows 8+ and 32 or 64 bit

XP Unattended CD/DVD creator - Version 4.1.7
Sample xml + Setupcomplete + Add Right click .wim Windows 7 or Windows 8/8.1

#24
FireGeier

FireGeier

    Advanced Member

  • Member
  • PipPipPip
  • 405 posts
  • Joined 24-October 05
You're right maxXPsoft! It's described in WAIK.chm. My mistake. This part got lost by any of the copy and paste procedures to build the guide. :whistle:

Sorry for that!

Regards,
Martin

#25
FireGeier

FireGeier

    Advanced Member

  • Member
  • PipPipPip
  • 405 posts
  • Joined 24-October 05
I've updated the Guide. Available now:

2. Installing Tools
3. Prepare Lab System
4. VU Batch Modules

Furthermore the Updates section is including the batch now.

Regards,
Martin




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users