Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



Sign in to follow this  
msdemich

nLite 1.3 Allow user creation (or rename) on install.

Recommended Posts

My nLite CDs used to allow me to name my user during install. But now with 1.3 it will not allow me to rename the user on install but only after install. XP Install doesn't even prompt me to change the default username "administrator" even though UnattendMode=ProvideDefault.

Am I doing something wrong?

Thanks

Share this post


Link to post
Share on other sites

I think u removed "out of box experience(OOBE)" and/or "internet explorer core" from "operating system options" in components

> use nlite again and in components hit "Compatibility" and select "windows activation and sysprep"

Edited by zikozoko

Share this post


Link to post
Share on other sites

Thanks i'll try that now.

EDIT: Under "Operating System Options" I only removed the "search assistant" and the "Tour". Do I need them in order to allow user rename during install?

Thanks again.

Edited by msdemich

Share this post


Link to post
Share on other sites

no u don't need them,

> but do u use unattended ? if u do then: disable "active" option from administrator account in users tab

Share this post


Link to post
Share on other sites
but do u use unattended ? if u do then: disable "active" option from administrator account in users tab

Thanks! I had the default account "active" box checked. But when I try to proceed with that box unchecked I get the error

"You should have at least one active user or you wont be able to login"

any ideas?

Edited by msdemich

Share this post


Link to post
Share on other sites

Administrator account must be remain acctive for installtion of Windows. If it also disable so windows Dos't have any user to logon so error occored and XP will abnormal.

Share this post


Link to post
Share on other sites
Administrator account must be remain acctive for installtion of Windows. If it also disable so windows Dos't have any user to logon so error occored and XP will abnormal.

If this is true, then how is it possible to get OOBE to run at all?

Share this post


Link to post
Share on other sites
but do u use unattended ? if u do then: disable "active" option from administrator account in users tab

i meant :don't use active administrator if u add your account and to make only your account active but if u didn't add any accounts u must keep admin account active

and for OOBE just do what i told u before in in my first post and every thing will be fine

Share this post


Link to post
Share on other sites

Sorry, I still don't understand.

I do not disable OOBE in nLite, and I do not remove any required components. If I check "active" for the administrator account the install will skip OOBE. If I uncheck "active" ont he administrator account (and bypass the warning) then Windows will install but I cannot login (blank welcome screen).

All I want to do is allow the user to create his own username on install.

Share this post


Link to post
Share on other sites
do u use autologon?

After checking... yes I do.

So should I click that drop-down menu and select "none" for autologon?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×