Sign in to follow this  
Followers 0
Offler

"Not Enough Memory" error discussion

31 posts in this topic

Hi. i was trying to fix this issue because for me is necessary to run som dos based aplications even in windows and this can cause serious errors while running them - including installation of Unofficial service pack. I thing i found a fix.

There are several reasons why this error occur. Mostly is caused by some graphics adapters, or by large ram and by system settings in config sys and system.ini.

Fixing of problem depends on the reason of memory insufficiency.

1. Dos based programs

- it is absolutely necessary for them to have enough memory to run. Mostly it means conventional memory.

2. Command.com and command line programs (*.bat, mem, or other w32 apps running in dos window)

- here are mixed reasons why the will not run. They need conventional memory, and they need classic windows memory to run.

3. Windows based applications

- here is only one reason - lack of free system ram.

This error occurs even when you have really large ram and have large virtual memory swapfile so the reason is not the amount of ram at all, but mostly the memory management.

I used some critical applications where this error can cause trouble to diagnose the problem and now i am sure that it is caused by too large MaxFileCache value.

Here are the lines which i used in system ini and fixed problem.

[vcache]

MaxFileCache=131072

MinFileCache=4096

chunksize=2048

namecache=4096

directorycache=96

To prove that these settings are correct i tried some things.

1.I opened You tube and play any video, then i turned on TV tuner and i watched both videos. If one of them goes blank or is frozen it means that memory is consumed. With setting above it didnt occured.

2. with tv tuner and you tube opened i ran Ultima online by *.bat file. It ran correctly. Then i ran command.com and it worked.

(ultima itself has trouble with lack of memory)

3. Opened Notepad/Metapad and selected quite large text and used copy/paste. With the setting aboe it worked without error.

This positive state didnt changed even when i was using apps for hours without restart.

If the MaxFileCache is larger than 131072 all "Not enough memory" errors appeared again - when the number was larger the intensity of memory errors was greater.

This error is probably linked also with hardware construction and this is the thing i want to discuss

I have 2 HDD, 2 CD roms, Ati Radeon 9800XT, 1,5 gb RAM. I need a feedback from somebody who is using more or less peripherals, different graphics and ram.

System has 1024 Mb of ram and 512 mb of Ramdisk, where the win386.swp is stored.

Try to use vcache settings i have posted and then try to raise Maxfilecache. Good diagnostic tool is any video playing and attempt to run Command line, or copy/pasting blocks of text in notepad.

Before testing be sure that you have enough free conventional memory (at least 450-500 kb)

Report if memory error occur while using 131072 kb of maxfilecache - send here your Vcache section of system ini, config sys, and autoexec.bat file.

Edited by Offler
0

Share this post


Link to post
Share on other sites
... system.ini:

[vcache]

directorycache=96

directorycache is invalid entry, does not exist anywhere.

HTH

0

Share this post


Link to post
Share on other sites

this was my source:

http://www.thpc.info/ram/vcache.html

link is on your page and i have no possibility to check which entries are valid or not except clasiccal "try and fail" debugging.

Only entry which matters is Maxfilecache. question is why and how it fixes our trouble...

0

Share this post


Link to post
Share on other sites

The Windows 32-bit protected-mode cache driver (Vcache) determines the maximum cache size based on the amount of RAM that is present when Windows starts. Vcache then reserves enough memory addresses to permit it to access a cache of the maximum size so that it can increase the cache to that size if needed. These addresses are allocated in a range of virtual addresses from 0xC0000000 through 0xFFFFFFFF (3 to 4 gigabytes) known as the system arena.

On computers with large amounts of RAM, the maximum cache size can be large enough that Vcache consumes all of the addresses in the system arena, leaving no virtual memory addresses available for other functions such as opening an MS-DOS prompt (creating a new virtual machine).

0

Share this post


Link to post
Share on other sites
thanks a lot for explanation.

A pleasure, interestingly from previous research I understand the vcache driver is internally limited to a maximum of 800 meg, if this could be altered and its other interupts adjusted, I wonder if none of the system.ini tricks would be needed allowing upto the max 4 gig of ram on a 32bit system

0

Share this post


Link to post
Share on other sites

well the memory management of w98 is quite a mystery for me.

I have 1,5 gb of ram right now and 512 mb is used as ramdisk with swapfile. Somebody here mentioned that win98 does not use Upper memory but if i let it unfilled i cant start my machine and i need to raise amount of ramdisk to 700 mb... If i use umbfill system can start with 1024 mb or ram and 512 mb of ramdisk

I wonder how it works if win98 really dont use free upper memory.

0

Share this post


Link to post
Share on other sites
well the memory management of w98 is quite a mystery for me.

I have 1,5 gb of ram right now and 512 mb is used as ramdisk with swapfile. Somebody here mentioned that win98 does not use Upper memory but if i let it unfilled i cant start my machine and i need to raise amount of ramdisk to 700 mb... If i use umbfill system can start with 1024 mb or ram and 512 mb of ramdisk

I wonder how it works if win98 really dont use free upper memory.

As far as i am aware upper memory blocks in the upper memory area are not available to win98 without a driver such as umbpci which allows them to be used as normal memory if any is left, after any memory resident progs,ramdisk/drivers have been loaded. By disabling your shadow rom and having your drivers loaded from its area. Being that himem.sys has been called via io.sys then extended before a ramdisk has been created via config.sys,autoexec etc, if this results in vcache.vxd only seeing the remaining 1 gig of ram not the full 1.5 gig and allows you to boot normally.

Edited by oscardog
0

Share this post


Link to post
Share on other sites
Hi. i was trying to fix this issue because for me is necessary to run som dos based aplications even in windows and this can cause serious errors while running them - including installation of Unofficial service pack. I thing i found a fix.

There are several reasons why this error occur. Mostly is caused by some graphics adapters, or by large ram and by system settings in config sys and system.ini.

Fixing of problem depends on the reason of memory insufficiency.

1. Dos based programs

- it is absolutely necessary for them to have enough memory to run. Mostly it means conventional memory.

2. Command.com and command line programs (*.bat, mem, or other w32 apps running in dos window)

- here are mixed reasons why the will not run. They need conventional memory, and they need classic windows memory to run.

3. Windows based applications

- here is only one reason - lack of free system ram.

This error occurs even when you have really large ram and have large virtual memory swapfile so the reason is not the amount of ram at all, but mostly the memory management.

I used some critical applications where this error can cause trouble to diagnose the problem and now i am sure that it is caused by too large MaxFileCache value.

Here are the lines which i used in system ini and fixed problem.

[vcache]

MaxFileCache=131072

MinFileCache=4096

chunksize=2048

namecache=4096

directorycache=96

To prove that these settings are correct i tried some things.

1.I opened You tube and play any video, then i turned on TV tuner and i watched both videos. If one of them goes blank or is frozen it means that memory is consumed. With setting above it didnt occured.

2. with tv tuner and you tube opened i ran Ultima online by *.bat file. It ran correctly. Then i ran command.com and it worked.

(ultima itself has trouble with lack of memory)

3. Opened Notepad/Metapad and selected quite large text and used copy/paste. With the setting aboe it worked without error.

This positive state didnt changed even when i was using apps for hours without restart.

If the MaxFileCache is larger than 131072 all "Not enough memory" errors appeared again - when the number was larger the intensity of memory errors was greater.

This error is probably linked also with hardware construction and this is the thing i want to discuss

I have 2 HDD, 2 CD roms, Ati Radeon 9800XT, 1,5 gb RAM. I need a feedback from somebody who is using more or less peripherals, different graphics and ram.

System has 1024 Mb of ram and 512 mb of Ramdisk, where the win386.swp is stored.

Try to use vcache settings i have posted and then try to raise Maxfilecache. Good diagnostic tool is any video playing and attempt to run Command line, or copy/pasting blocks of text in notepad.

Before testing be sure that you have enough free conventional memory (at least 450-500 kb)

Report if memory error occur while using 131072 kb of maxfilecache - send here your Vcache section of system ini, config sys, and autoexec.bat file.

Warning, there is a bug that causes the following:

Setting the swap file to bigger than 768 MB causes Windows to think there isn't enough RAM to initialize the GUI!

0

Share this post


Link to post
Share on other sites

I do not know whether this applies to the discussion or not, but i have 128 MB ram and 380 MB swap file, i had a "Not enough Memory error" once and i just raised the swap file size to 420 MB and it was fixed. The Maxfilecache setting is at default 393216. I do not use any minfilecache setting.

0

Share this post


Link to post
Share on other sites
I do not know whether this applies to the discussion or not, but i have 128 MB ram and 380 MB swap file, i had a "Not enough Memory error" once and i just raised the swap file size to 420 MB and it was fixed. The Maxfilecache setting is at default 393216. I do not use any minfilecache setting.

How do you raise the swap file size?

0

Share this post


Link to post
Share on other sites
How do you raise the swap file size?
Start->Settings->Control Panel->System, then "Performance" tab, "Virtual Memory" box; careful now! Usually "Let Windows Manage..." is the best option unless you may be running out of HDD space. Before you change anything, first check the current Windows\WIN386.SWP size and your Free HDD space. If you give too big/too small, you might lock up the system (correction on this statement?). Also ref. RJARRRPCGP's comment/info...

BTW, good info provided. Admittedly I'm shy of in-depth knowledge of these other points... Perhaps there is a relationship (? input, please)...

Edited by submix8c
0

Share this post


Link to post
Share on other sites
How do you raise the swap file size?
Start->Settings->Control Panel->System, then "Performance" tab, "Virtual Memory" box; careful now! Usually "Let Windows Manage..." is the best option unless you may be running out of HDD space. Before you change anything, first check the current Windows\WIN386.SWP size and your Free HDD space. If you give too big/too small, you might lock up the system (correction on this statement?). Also ref. RJARRRPCGP's comment/info...

Yes exactly. One more thing: If you have two hard drives, then select the hard drive for swap which does not has operating system on it. This way read and writes are increased.

0

Share this post


Link to post
Share on other sites

Generally the more amount of Ram you have, the larger swapfile you have and the larger Vcache is defined this error occurs more and more times :)

Technically Windows 98 SE with some patches can have up to 1gb of classical ram and another 4 gb of virtual ram (swapfile) and of course best performance of virtual ram can be gained with large ramdriver.

the question is if is somebody so mad to build up a system with 5 gigs of ram :)

To use 1gb of ram and 4gb of virtual ram located on harddisk is quite possible but the question is if it can improve or degrade the system performance. At all it is more memory that can be used with a single app.

i tried to set Virtual memory to 4gigs... system was able to run but i experienced trouble. Sound driver was failing..

Edited by Offler
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.