ilko_t

How to install Windows from USB- WinSetupFromUSB with GUI

2,144 posts in this topic

GUI mode started from second disk, but gives error NTLDR not found , since XP Bootfiles were made on first harddisk. Booting from first harddisk will let you continue with GUI mode, since boot.ini refers to Install partition.
Thanks, so it works as expected.
The BOOTWS folder when adjusted with the mapping strategy of cdob will do better and create always XP bootfiles at the Install partition.
It will force them on the active partition on the second disk in this case. What happens if you use same entries and install to the first disk? How do you know that one is installing to first or second disk?
Yes, strange indeed, left+right arrow key do the up/down select work.
I recall something seen on boot-land about the nested config files, have to search a bit. If it's still up Monday will post there to see what Tinybit and the rest of the band have in mind.

Mind you, it's early stage. Other BIOSes may honor boot order and re-arange disk numbering. SATA/IDE mode may also matter.

0

Share this post


Link to post
Share on other sites
...Other BIOSes may honor boot order and re-arange disk numbering. SATA/IDE mode may also matter.

Quick proof- just tested on motherboard MSI G31M3, 2 SATA disks in IDE mode, no option for AHCI/SATA.

Upon changing boot order in BIOS, hard drive numbering changes too, no matter what port they are connected to, booting from USB using F11 hotkey.

0

Share this post


Link to post
Share on other sites

Wow, great. Now i have on one flash Windows 2003, Windows 7 and Windows FLP!!! Want also add Ubuntu Linux. Please make support for grub4dos Ununtu Linux feature.

0

Share this post


Link to post
Share on other sites

In the current version Grub4Dos already run Ubuntu, but loading fails due to wrong directory structure.

0

Share this post


Link to post
Share on other sites

What did you exactly do?

You need to copy the ISO file manually and add the mentioned in that topic entries to menu.lst, according to Ubuntu version.

0

Share this post


Link to post
Share on other sites
It will force them on the active partition on the second disk in this case. What happens if you use same entries and install to the first disk? How do you know that one is installing to first or second disk?

The user will know where he wants to install and can select from grub4dos menu the TXT-mode start entry that is most suitable to his needs. So when you offer both strategies, then you can deal with most configurations.

0

Share this post


Link to post
Share on other sites

Did you miss this post?

...Other BIOSes may honor boot order and re-arange disk numbering. SATA/IDE mode may also matter.

Quick proof- just tested on motherboard MSI G31M3, 2 SATA disks in IDE mode, no option for AHCI/SATA.

Upon changing boot order in BIOS, hard drive numbering changes too, no matter what port they are connected to, booting from USB using F11 hotkey.

How would an average user know what his BIOS does, in order to select the appropriate entry? Which one it would be? The one shifting all internal disks one position up and USB disk last, or the desired disk mapped to hd0? :blink:

One likes to manage boot via a boot loader, other prefers to use BIOS boot order.

This is going to be a little mess, I'd stick with the default Setup behaviour, whatever BIOS provides as first internal disk, boot files go there. This is also well known and documented behaviour. Next would be Vista/7, behaviour is the same. There we cannot manipulate it, for now.

An advanced user willing to take the other disk out of the equation should disconnect or disable that disk during setup, or amend entries manually. This goes to the help files.

I 'd now rather focus on more important things to fix and add ;)

0

Share this post


Link to post
Share on other sites
How would an average user know what his BIOS does, in order to select the appropriate entry?

Once ruled out Crystal balls, Tarots and I-Ching, not much remains. :whistle:

Patterns of dust on hard disk covers? But it won't work for new systems. :unsure:

Pig spleen has not proved as very reliable in other fields of prediction, AFAIK:

http://www.almanac.com/image/pig-spleen-we...rediction-chart

pigspleenchart.250.gif

:thumbup

jaclaz

0

Share this post


Link to post
Share on other sites
This is going to be a little mess, I'd stick with the default Setup behaviour, whatever BIOS provides as first internal disk, boot files go there.

If someone has a computer running Windows 7 and someday he decides to place an extra harddisk and

will Install XP from USB-stick using small ISO method,

then booting from second harddisk will fail and booting with Windows 7 will fail (BOOTMGR BootSector is gone).

I thought may be it is possible to prevent such problems, allthough it is default Windows behavior.

But as you say, other things can be more important to fix and add. B)

Edited by wimb
0

Share this post


Link to post
Share on other sites

ilko_t, thank's for link.

Tested this grub config on desktop PC and netbook Asus Eee PC 900.

title Start ubuntu-9.10-desktop-i386.iso from partition 0
find --set-root /pmagic/ubuntu-9.10-desktop-i386.iso
map /pmagic/ubuntu-9.10-desktop-i386.iso (0xff)
map --hook
root (0xff)
kernel /casper/vmlinuz boot=casper iso-scan/filename=/pmagic/ubuntu-9.10-desktop-i386.iso quiet splash --
initrd /casper/initrd.lz
boot

Work very nice for me.

Have only problem with notebook Dell Vostro 1000.

Boot fail with this screen.

ubuntufail.png

P.S. For Ubuntu 9.04 used initrd.gz, for Ubuntu 9.10 initrd.lz

0

Share this post


Link to post
Share on other sites

@NT Man

I'd do the following:

- chkdsk on the USB disk

- compare MD5 sum for the ISO

- change in BIOS SATA mode to IDE/compatible, if possible

- test the memory modules, also by removing each of them if 2.

- look at Ubuntu's forum for hints, additional kernel parameters may get you going, start with the ones mentioned here, several are posted:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/172937

- ask for help in Ubuntu's forum

0

Share this post


Link to post
Share on other sites

Thank you, but the my problem seems in GRUB.

That the same image recorded on CD-R boot up normally on Vostro 1000.

Edited by NT Man
0

Share this post


Link to post
Share on other sites

It could be also because you are starting it from USB, thus additional kernel parameters may be needed for this particular machine, or other factors, not present when booted from a CD may matter.

Sorry, I have no other hints, you've got plenty of them to try in the referenced link.

And by the way, to be technically correct- it's Grub4dos, not GRUB, although grub4dos developers are also actively participating in GRUB2 developing ;)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.